Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Controller Area Network (CAN) interface module for Python" |
| 2 | SECTION = "devel/python" |
| 3 | LICENSE = "LGPL-3.0-only" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e6a600fd5e1d9cbde2d983680233ad02" |
| 5 | |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 6 | SRC_URI[sha256sum] = "6ad50f4613289f3c4d276b6d2ac8901d776dcb929994cce93f55a69e858c595f" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 7 | |
| 8 | PYPI_PACKAGE="python-can" |
| 9 | |
| 10 | inherit pypi setuptools3 |
| 11 | |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame] | 12 | RDEPENDS:${PN} += " \ |
| 13 | python3-aenum \ |
| 14 | python3-asyncio \ |
| 15 | python3-codecs \ |
| 16 | python3-compression \ |
| 17 | python3-ctypes \ |
| 18 | python3-fcntl \ |
| 19 | python3-json \ |
| 20 | python3-logging \ |
| 21 | python3-misc \ |
| 22 | python3-netserver \ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 23 | python3-packaging \ |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame] | 24 | python3-pkg-resources \ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 25 | python3-setuptools \ |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame] | 26 | python3-sqlite3 \ |
| 27 | python3-typing-extensions \ |
| 28 | python3-wrapt \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 29 | " |