Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 1 | SUMMARY = "Python interface to Pocketsphinx libraries." |
| 2 | DESCRIPTION = "Pythonsphinx is an Open source large vocabulary, speaker-independent continuous speech recognition engines." |
| 3 | HOMEPAGE = "https://github.com/cmusphinx/pocketsphinx" |
| 4 | SECTION = "devel/python" |
| 5 | LICENSE = "BSD-2-Clause | BSD-3-Clause | MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c4d720cdc9c6953091f65e8b01524bb4" |
| 7 | |
| 8 | SRC_URI += "file://0001-cython-Use-cythyon3-in-cmake-check.patch" |
| 9 | SRC_URI[sha256sum] = "27f4de0ca2d2bce391ce87eaab84fe6f0bc059b306fd1702d5fe6549b66e1586" |
| 10 | |
| 11 | inherit cmake pkgconfig pypi python3native |
| 12 | |
| 13 | DEPENDS += "swig-native python3-cython-native python3-scikit-build-native gstreamer1.0 gstreamer1.0-plugins-base" |
| 14 | |
| 15 | EXTRA_OECMAKE += "-DBUILD_GSTREAMER=ON" |
| 16 | |
| 17 | PACKAGES += "${PN}-models ${MLPREFIX}gstreamer1.0-pocketsphinx" |
| 18 | |
| 19 | FILES:${MLPREFIX}gstreamer1.0-pocketsphinx = "${libdir}/gstreamer-1.0/" |
| 20 | FILES:${PN}-models = "${datadir}/pocketsphinx/model" |