Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 1 | SUMMARY = "Allows you to use fixtures in @pytest.mark.parametrize." |
| 2 | DESCRIPTION = "Use your fixtures in @pytest.mark.parametrize. \ |
| 3 | \ |
| 4 | This project was inspired by pytest-lazy-fixture.\ |
| 5 | \ |
| 6 | Improvements that have been made in this project:\ |
| 7 | \ |
| 8 | * You can use fixtures in any data structures\ |
| 9 | * You can access the attributes of fixtures\ |
| 10 | * You can use functions in fixtures" |
| 11 | HOMEPAGE = "https://github.com/dev-petrov/pytest-lazy-fixtures" |
| 12 | LICENSE = "MIT" |
| 13 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4475e66fcfabe27395e6764c8f69c876" |
| 14 | |
| 15 | SRC_URI[sha256sum] = "066b253a94c249e6d9cdfad465e2503d2219139fb468d8f687243dfde39ab9cb" |
| 16 | |
| 17 | inherit pypi python_poetry_core |
| 18 | |
| 19 | PYPI_PACKAGE = "pytest_lazy_fixtures" |
| 20 | |
| 21 | RDEPENDS:${PN} = "python3-pytest" |