blob: ed5175fcf79a24668b8190f26dd4cab5058d3256 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A libudev binding"
2
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "LGPL-2.1-or-later"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00004LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
5
Andrew Geissler3eeda902023-05-19 10:14:02 -05006SRC_URI[sha256sum] = "75e54d37218f5ac45b0da1f0fd9cc5e526a3cac3ef1cfad410cf7ab338b01471"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007
8inherit pypi setuptools3
9
10do_configure:prepend() {
11 sed -i "/import pyudev/d" ${S}/setup.py
12 sed -i "s/str(pyudev.__version__)/'${PV}'/g" ${S}/setup.py
13}
14
15RDEPENDS:${PN} = "\
Patrick Williams39653562024-03-01 08:54:02 -060016 python3-ctypes \
17 python3-misc \
18 python3-six \
19 python3-threading \
20 python3-fcntl \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000021 libudev \
22"