blob: 8f5ef415c646164d32fda2954d8a54be17f776b1 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "RAR archive reader for Python"
2HOMEPAGE = "https://github.com/markokr/rarfile"
3LICENSE = "ISC"
4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2f31e224cbf0c29cb6c55f2bae0e165f"
6
7inherit setuptools3
8
9SRC_URI[sha256sum] = "db60b3b5bc1c4bdeb941427d50b606d51df677353385255583847639473eda48"
10
11inherit pypi
12
13PYPI_PACKAGE="rarfile"
14
15RDEPENDS:${PN} += "\
16 p7zip \
Patrick Williams39653562024-03-01 08:54:02 -060017 python3-core \
18 python3-datetime \
19 python3-crypt \
20 python3-io \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060021"
22
23BBCLASSEXTEND = "native nativesdk"