Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Style preserving TOML library" |
| 2 | HOMEPAGE = "https://pypi.org/project/tomlkit/" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=31aac0dbc1babd278d5386dadb7f8e82" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "75baf5012d06501f07bee5bf8e801b9f343e7aac5a92581f20f80ce632e6b5a4" |
| 7 | |
| 8 | inherit pypi python_poetry_core ptest |
| 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
| 14 | RDEPENDS:${PN} += " \ |
| 15 | python3-datetime \ |
| 16 | python3-profile \ |
| 17 | python3-stringold \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 21 | python3-poetry-core \ |
| 22 | python3-pytest \ |
| 23 | python3-pyyaml \ |
| 24 | python3-unittest-automake-output \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 25 | " |
| 26 | |
| 27 | do_install_ptest() { |
| 28 | install -d ${D}${PTEST_PATH}/tests |
| 29 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 30 | } |
| 31 | |
| 32 | BBCLASSEXTEND = "native nativesdk" |