blob: d4162a110bbd94b5511d50d3099ce523a0040c10 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Style preserving TOML library"
2HOMEPAGE = "https://pypi.org/project/tomlkit/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=31aac0dbc1babd278d5386dadb7f8e82"
5
6SRC_URI[sha256sum] = "75baf5012d06501f07bee5bf8e801b9f343e7aac5a92581f20f80ce632e6b5a4"
7
8inherit pypi python_poetry_core ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN} += " \
15 python3-datetime \
16 python3-profile \
17 python3-stringold \
18"
19
20RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060021 python3-poetry-core \
22 python3-pytest \
23 python3-pyyaml \
24 python3-unittest-automake-output \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060025"
26
27do_install_ptest() {
28 install -d ${D}${PTEST_PATH}/tests
29 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
30}
31
32BBCLASSEXTEND = "native nativesdk"