Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Python 2 and 3 compatibility library" |
| 2 | HOMEPAGE = "https://xlsxwriter.readthedocs.io" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=12d9fac1f0049be71ab5aa4a78da02b0" |
| 6 | |
| 7 | inherit pypi setuptools3 |
| 8 | |
| 9 | PYPI_PACKAGE = "XlsxWriter" |
| 10 | |
| 11 | RDEPENDS:${PN} += " \ |
| 12 | python3-crypt \ |
| 13 | python3-datetime \ |
| 14 | python3-compression \ |
| 15 | python3-numbers \ |
| 16 | python3-io \ |
| 17 | " |
| 18 | |
| 19 | SRC_URI[sha256sum] = "de810bf328c6a4550f4ffd6b0b34972aeb7ffcf40f3d285a0413734f9b63a929" |
| 20 | |
| 21 | BBCLASSEXTEND = "native nativesdk" |