Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Provides cryptographic recipes and primitives to python developers" |
| 2 | HOMEPAGE = "https://cryptography.io/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "Apache-2.0 | BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4 \ |
| 6 | file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \ |
| 7 | file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b \ |
| 8 | " |
| 9 | LDSHARED += "-pthread" |
| 10 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "6fe07eec95dfd477eb9530aef5bead34fec819b3aaf6c5bd6d20565da607bfe1" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 12 | |
| 13 | SRC_URI += "file://0001-pyproject.toml-remove-benchmark-disable-option.patch \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 14 | file://check-memfree.py \ |
| 15 | file://run-ptest \ |
| 16 | " |
| 17 | |
| 18 | require ${BPN}-crates.inc |
| 19 | |
| 20 | inherit pypi python_setuptools3_rust cargo-update-recipe-crates pkgconfig |
| 21 | |
| 22 | DEPENDS += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 23 | python3-cffi-native \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 24 | " |
| 25 | |
| 26 | RDEPENDS:${PN} += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 27 | python3-cffi \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 28 | " |
| 29 | |
| 30 | RDEPENDS:${PN}:append:class-target = " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 31 | python3-numbers \ |
| 32 | python3-threading \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 33 | " |
| 34 | |
| 35 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 36 | python3-bcrypt \ |
| 37 | python3-cryptography-vectors (= ${PV}) \ |
| 38 | python3-hypothesis \ |
| 39 | python3-iso8601 \ |
| 40 | python3-mmap \ |
| 41 | python3-pretend \ |
| 42 | python3-psutil \ |
| 43 | python3-pytest \ |
| 44 | python3-unittest-automake-output \ |
| 45 | python3-pytest-subtests \ |
| 46 | python3-pytz \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 47 | " |
| 48 | |
| 49 | inherit ptest |
| 50 | |
| 51 | do_install_ptest() { |
| 52 | install -D ${WORKDIR}/check-memfree.py ${D}${PTEST_PATH}/ |
| 53 | install -d ${D}${PTEST_PATH}/tests |
| 54 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 55 | # remove test_x509.py as it needs benchmark and we don't |
| 56 | # want to introduce the benchmark dependency |
| 57 | rm -rf ${D}${PTEST_PATH}/tests/bench/test_x509.py |
| 58 | install -d ${D}${PTEST_PATH}/tests/hazmat |
| 59 | cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/ |
| 60 | cp -r ${S}/pyproject.toml ${D}${PTEST_PATH}/ |
| 61 | } |
| 62 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 63 | FILES:${PN}-dbg += " \ |
| 64 | ${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/hazmat/bindings/.debug \ |
| 65 | " |
| 66 | |
| 67 | BBCLASSEXTEND = "native nativesdk" |