Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 1 | SUMMARY = "A sophisticated Numeric Processing Package for Python" |
| 2 | HOMEPAGE = "https://numpy.org/" |
| 3 | DESCRIPTION = "NumPy is the fundamental package needed for scientific computing with Python." |
| 4 | SECTION = "devel/python" |
| 5 | LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF-2.0 & Apache-2.0 & MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a752eb20459cf74a9d84ee4825e8317c" |
| 7 | |
| 8 | SRCNAME = "numpy" |
| 9 | |
| 10 | SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${SRCNAME}-${PV}.tar.gz \ |
| 11 | file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \ |
| 12 | file://0001-numpy-core-Define-RISCV-32-support.patch \ |
| 13 | file://fix_reproducibility.patch \ |
| 14 | file://run-ptest \ |
| 15 | " |
| 16 | SRC_URI[sha256sum] = "2a02aba9ed12e4ac4eb3ea9421c420301a0c6460d9830d74a9df87efa4912010" |
| 17 | |
| 18 | GITHUB_BASE_URI = "https://github.com/numpy/numpy/releases" |
| 19 | UPSTREAM_CHECK_REGEX = "releases/tag/v?(?P<pver>\d+(\.\d+)+)$" |
| 20 | |
| 21 | DEPENDS += "python3-cython-native" |
| 22 | |
| 23 | inherit ptest setuptools3 github-releases |
| 24 | |
| 25 | S = "${WORKDIR}/numpy-${PV}" |
| 26 | |
| 27 | CLEANBROKEN = "1" |
| 28 | |
| 29 | do_compile:prepend() { |
| 30 | export NPY_DISABLE_SVML=1 |
| 31 | } |
| 32 | |
| 33 | FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a" |
| 34 | |
| 35 | # install what is needed for numpy.test() |
| 36 | RDEPENDS:${PN} = "python3-unittest \ |
| 37 | python3-difflib \ |
| 38 | python3-pprint \ |
| 39 | python3-pickle \ |
| 40 | python3-shell \ |
| 41 | python3-doctest \ |
| 42 | python3-datetime \ |
| 43 | python3-misc \ |
| 44 | python3-mmap \ |
| 45 | python3-netclient \ |
| 46 | python3-numbers \ |
| 47 | python3-pydoc \ |
| 48 | python3-pkgutil \ |
| 49 | python3-email \ |
| 50 | python3-compression \ |
| 51 | python3-ctypes \ |
| 52 | python3-threading \ |
| 53 | python3-multiprocessing \ |
| 54 | python3-json \ |
| 55 | " |
| 56 | RDEPENDS:${PN}-ptest += "python3-pytest \ |
| 57 | python3-hypothesis \ |
| 58 | python3-sortedcontainers \ |
| 59 | python3-resource \ |
| 60 | python3-typing-extensions \ |
| 61 | ldd \ |
| 62 | " |
| 63 | |
| 64 | BBCLASSEXTEND = "native nativesdk" |