Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "the blessed package to manage your versions by scm tags" |
| 2 | HOMEPAGE = "https://pypi.org/project/setuptools-scm/" |
| 3 | DESCRIPTION = "setuptools_scm handles managing your Python package \ |
| 4 | versions in SCM metadata instead of declaring them as the version \ |
| 5 | argument or in a SCM managed file." |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=838c366f69b72c5df05c96dff79b35f2" |
| 8 | |
| 9 | SRC_URI[sha256sum] = "b5f43ff6800669595193fd09891564ee9d1d7dcb196cab4b2506d53a2e1c95c7" |
| 10 | |
| 11 | inherit pypi python_setuptools_build_meta |
| 12 | |
| 13 | UPSTREAM_CHECK_REGEX = "scm-(?P<pver>.*)\.tar" |
| 14 | |
| 15 | DEPENDS += "python3-tomli-native python3-packaging-native python3-typing-extensions-native" |
| 16 | |
| 17 | RDEPENDS:${PN} = "\ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 18 | python3-packaging \ |
| 19 | python3-pip \ |
| 20 | python3-pyparsing \ |
| 21 | python3-setuptools \ |
| 22 | python3-tomli \ |
| 23 | python3-typing-extensions \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 24 | " |
| 25 | |
| 26 | RDEPENDS:${PN}:append:class-target = " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 27 | python3-debugger \ |
| 28 | python3-json \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 29 | " |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |