blob: 7a049733bee7067701b1e0171c6bd0875f87a7a5 [file] [log] [blame]
Patrick Williams2a254922023-08-11 09:48:11 -05001SUMMARY = "Simple construction, analysis and modification of binary data."
2HOMEPAGE = "https://github.com/scott-griffiths/bitstring"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=661f450e2c0aef39b4b15597333444a7"
5
Andrew Geissler220dafd2023-10-04 10:18:08 -05006SRC_URI[sha256sum] = "c22283d60fd3e1a8f386ccd4f1915d7fe13481d6349db39711421e24d4a9cccf"
Patrick Williams2a254922023-08-11 09:48:11 -05007
8PYPI_PACKAGE = "bitstring"
9
10inherit pypi python_poetry_core
11
12RDEPENDS:${PN} = "\
13 ${PYTHON_PN}-core \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-mmap \
16 ${PYTHON_PN}-numbers \
17"
18
19BBCLASSEXTEND = "native nativesdk"