blob: e5e84ffac4b2065760ee23a46dbe14dc8f53241e [file] [log] [blame]
Chris Austen9d3325a2015-10-24 19:34:11 -05001SUMMARY = "Phosphor OpenBMC OEM Commands for OpenPOWER systems"
2DESCRIPTION = "Phosphor OpenBMC IPMI OEM commands for OpenPOWER based systems"
3HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-oem"
4PR = "r1"
5
6RRECOMMENDS_${PN} = "virtual/obmc-phosphor-host-ipmi-hw"
7
8inherit obmc-phosphor-license
9
10DEPENDS += "systemd \
11 host-ipmid \
12 "
Chris Austenf6d294d2016-01-23 18:00:11 -060013TARGET_CFLAGS += "-fpic"
Chris Austen9d3325a2015-10-24 19:34:11 -050014
15
16RDEPENDS_${PN} += "libsystemd"
17
18
19
Milton D. Miller II5d4f9c52016-03-04 15:31:30 -060020#SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-oem"
21SRC_URI += "git://github.com/anoo1/openpower-host-ipmi-oem;protocol=https;branch=flash"
Chris Austen9d3325a2015-10-24 19:34:11 -050022
Milton D. Miller II5d4f9c52016-03-04 15:31:30 -060023SRCREV = "187bfced3d86fae7c93e3772fa7fa028d02e2c18"
Chris Austen9d3325a2015-10-24 19:34:11 -050024
25FILES_${PN} += "${libdir}/host-ipmid/*.so"
26FILES_${PN}-dbg += "${libdir}/host-ipmid/.debug"
27
28S = "${WORKDIR}/git"
29
30do_install() {
31 install -m 0755 -d ${D}${libdir}/host-ipmid
32 install -m 0755 ${S}/*.so ${D}${libdir}/host-ipmid/
33}