Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 1 | SUMMARY = "The implementation of SOME/IP" |
| 2 | DESCRIPTION = "The vsomeip stack implements the http://some-ip.com/ \ |
| 3 | (Scalable service-Oriented MiddlewarE over IP (SOME/IP)) protocol." |
| 4 | HOMEPAGE = "https://github.com/COVESA/vsomeip" |
| 5 | SECTION = "net" |
| 6 | |
| 7 | LICENSE = "MPL-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9741c346eef56131163e13b9db1241b3" |
| 9 | |
| 10 | SRC_URI = "git://github.com/GENIVI/${BPN}.git;branch=master;protocol=https;name=vsomeip \ |
| 11 | file://0001-Fix-pkgconfig-dir-for-multilib.patch \ |
| 12 | file://0002-Install-example-configuration-files-to-etc-vsomeip.patch \ |
| 13 | file://0003-Do-not-build-external-gtest.patch \ |
| 14 | file://0004-Do-not-specify-PIE-flag-explicitly.patch \ |
Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 15 | file://0005-test-common-CMakeLists.txt-add-missing-link-with-dlt.patch \ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 16 | " |
| 17 | |
Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 18 | SRCREV = "02c199dff8aba814beebe3ca417fd991058fe90c" |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 19 | |
| 20 | COMPATIBLE_HOST:mips = "null" |
| 21 | COMPATIBLE_HOST:mips64 = "null" |
| 22 | COMPATIBLE_HOST:powerpc = "null" |
| 23 | COMPATIBLE_HOST:libc-musl = 'null' |
| 24 | |
| 25 | DEPENDS = "boost dlt-daemon googletest" |
| 26 | |
| 27 | S = "${WORKDIR}/git" |
| 28 | |
| 29 | inherit cmake pkgconfig |
| 30 | |
| 31 | EXTRA_OECMAKE = "-DINSTALL_LIB_DIR:PATH=${baselib} \ |
| 32 | -DINSTALL_CMAKE_DIR:PATH=${baselib}/cmake/vsomeip3 \ |
| 33 | " |
| 34 | |
| 35 | # For vsomeip-test |
| 36 | EXTRA_OECMAKE += "-DTEST_IP_MASTER=10.0.3.1 \ |
| 37 | -DTEST_IP_SLAVE=10.0.3.2 \ |
| 38 | -DTEST_IP_SLAVE_SECOND=10.0.3.3 \ |
| 39 | -DTEST_UID=1000 -DTEST_GID=1000 \ |
| 40 | " |
| 41 | |
| 42 | RDEPENDS:${PN}-test = "bash lsof" |
| 43 | |
| 44 | do_compile:append() { |
| 45 | cmake_runcmake_build --target examples |
| 46 | cmake_runcmake_build --target build_tests |
| 47 | } |
| 48 | |
| 49 | do_install:append() { |
| 50 | install -d ${D}/opt/${PN}-test/examples |
| 51 | install -m 0755 ${B}/examples/*-sample ${D}/opt/${PN}-test/examples |
| 52 | install -d ${D}/opt/${PN}-test/examples/routingmanagerd |
| 53 | install -m 0755 ${B}/examples/routingmanagerd/routingmanagerd \ |
| 54 | ${D}/opt/${PN}-test/examples/routingmanagerd |
| 55 | |
| 56 | install -d ${D}/opt/${PN}-test/test/test/common |
| 57 | cp -rf ${S}/test/common/examples_policies \ |
| 58 | ${D}/opt/${PN}-test/test/test/common/ |
Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 59 | install -m 0755 ${B}/test/common/libvsomeip_utilities.so \ |
| 60 | ${D}/opt/${PN}-test/test/test/common/ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 61 | |
| 62 | for d in unit_tests network_tests; do |
| 63 | install -d ${D}/opt/${PN}-test/test/$d |
| 64 | cp -f ${B}/test/$d/*test* ${D}/opt/${PN}-test/test/$d |
| 65 | done |
| 66 | } |
| 67 | |
| 68 | PACKAGES += "${PN}-test" |
| 69 | |
| 70 | FILES:${PN}-dbg += " \ |
| 71 | /opt/${PN}-test/.debug/* \ |
| 72 | " |
| 73 | FILES:${PN}-test = " \ |
| 74 | /opt/${PN}-test \ |
| 75 | " |