Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Window navigation construction toolkit" |
| 2 | LICENSE = "LGPL-2.0-only" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" |
| 4 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 5 | |
| 6 | inherit gnomebase gsettings gobject-introspection gettext features_check upstream-version-is-even |
| 7 | |
| 8 | DEPENDS = " \ |
| 9 | colord \ |
| 10 | geocode-glib \ |
| 11 | gcr \ |
| 12 | gnome-desktop \ |
| 13 | libgweather4 \ |
| 14 | lcms \ |
| 15 | libcanberra \ |
| 16 | geoclue \ |
| 17 | libnotify \ |
| 18 | upower \ |
| 19 | libwacom \ |
| 20 | virtual/libx11 \ |
| 21 | " |
| 22 | |
| 23 | # all these are mandatory |
| 24 | REQUIRED_DISTRO_FEATURES = "x11 polkit pulseaudio systemd gobject-introspection-data" |
| 25 | GIR_MESON_OPTION = "" |
| 26 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 27 | SRC_URI[archive.sha256sum] = "bb4dc46950e2a90f38f23225848856d2a7b1b718c89d0285ce197b7016bb1dc8" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 28 | |
| 29 | PACKAGECONFIG ??= " \ |
| 30 | cups nm \ |
| 31 | alsa gudev \ |
| 32 | smartcard \ |
| 33 | ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)} \ |
| 34 | " |
| 35 | PACKAGECONFIG[alsa] = "-Dalsa=true,-Dalsa=false,alsa-lib" |
| 36 | PACKAGECONFIG[cups] = "-Dcups=true,-Dcups=false,cups" |
| 37 | PACKAGECONFIG[gudev] = "-Dgudev=true,-Dgudev=false,libgudev" |
| 38 | PACKAGECONFIG[nm] = "-Dnetwork_manager=true,-Dnetwork_manager=false,networkmanager" |
| 39 | PACKAGECONFIG[smartcard] = "-Dsmartcard=true,-Dsmartcard=false,nss" |
| 40 | PACKAGECONFIG[wayland] = "-Dwayland=true,-Dwayland=false,wayland" |
| 41 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 42 | def gnome_verdir(v): |
| 43 | return oe.utils.trim_version(v, 1) |
| 44 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 45 | FILES:${PN} += " \ |
| 46 | ${systemd_user_unitdir} \ |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 47 | ${libdir}/gnome-settings-daemon-${@gnome_verdir("${PV}")}/libgsd.so \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 48 | " |