blob: e6380d9a20d55664d4f1c04d885176adcdbee9e6 [file] [log] [blame]
Patrick Williamsda295312023-12-05 16:48:56 -06001SUMMARY = "Monocypher is an easy-to-use crypto library"
2DESCRIPTION = "Monocypher is an easy to use, easy to deploy, \
3auditable crypto library written in portable C. It approaches the size of TweetNaCl and the speed of libsodium."
4HOMEPAGE = "https://monocypher.org/"
5SECTION = "libs"
6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://LICENCE.md;md5=6a251155d943c8531e01a139f3fc531a"
8
9SRC_URI = "git://github.com/LoupVaillant/Monocypher.git;protocol=https;branch=master"
10SRCREV = "0d85f98c9d9b0227e42cf795cb527dff372b40a4"
11
12S = "${WORKDIR}/git"
13
Patrick Williams169d7bc2024-01-05 11:33:25 -060014CFLAGS += "-pedantic -Wall -Wextra -O3"
15EXTRA_OEMAKE = "'PREFIX=${prefix}' 'DESTDIR=${D}' 'CFLAGS=${CFLAGS}' 'LIBDIR=${libdir}'"
Patrick Williamsda295312023-12-05 16:48:56 -060016
17do_compile() {
18 oe_runmake library
19}
20
21do_install() {
22 oe_runmake install-lib
23 oe_runmake install-pc
24}
25
26BBCLASSEXTEND = "native nativesdk"