Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 1 | SUMMARY = "Monocypher is an easy-to-use crypto library" |
| 2 | DESCRIPTION = "Monocypher is an easy to use, easy to deploy, \ |
| 3 | auditable crypto library written in portable C. It approaches the size of TweetNaCl and the speed of libsodium." |
| 4 | HOMEPAGE = "https://monocypher.org/" |
| 5 | SECTION = "libs" |
| 6 | LICENSE = "BSD-2-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENCE.md;md5=6a251155d943c8531e01a139f3fc531a" |
| 8 | |
| 9 | SRC_URI = "git://github.com/LoupVaillant/Monocypher.git;protocol=https;branch=master" |
| 10 | SRCREV = "0d85f98c9d9b0227e42cf795cb527dff372b40a4" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 14 | CFLAGS += "-pedantic -Wall -Wextra -O3" |
| 15 | EXTRA_OEMAKE = "'PREFIX=${prefix}' 'DESTDIR=${D}' 'CFLAGS=${CFLAGS}' 'LIBDIR=${libdir}'" |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 16 | |
| 17 | do_compile() { |
| 18 | oe_runmake library |
| 19 | } |
| 20 | |
| 21 | do_install() { |
| 22 | oe_runmake install-lib |
| 23 | oe_runmake install-pc |
| 24 | } |
| 25 | |
| 26 | BBCLASSEXTEND = "native nativesdk" |