Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Abseil is a cpp library like STL" |
| 2 | DESCRIPTION = "Abseil provides pieces missing from the C++ standard. Contains \ |
| 3 | additional useful libraries like algorithm, container, debugging, hash, memory, \ |
| 4 | meta, numeric, strings, synchronization, time, types and utility" |
| 5 | HOMEPAGE = "https://abseil.io/" |
| 6 | SECTION = "libs" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=df52c6edb7adc22e533b2bacc3bd3915" |
| 9 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 10 | PV = "20230802.1" |
| 11 | SRCREV = "fb3621f4f897824c0dbe0615fa94543df6192f30" |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 12 | BRANCH = "lts_2023_08_02" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 13 | SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH};protocol=https \ |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 14 | file://0001-absl-always-use-asm-sgidefs.h.patch \ |
| 15 | file://0002-Remove-maes-option-from-cross-compilation.patch \ |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 16 | file://abseil-ppc-fixes.patch \ |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 17 | file://0003-Remove-neon-option-from-cross-compilation.patch \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 18 | file://0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | " |
| 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | ASNEEDED:class-native = "" |
| 24 | ASNEEDED:class-nativesdk = "" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 25 | |
| 26 | inherit cmake |
| 27 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 28 | EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \ |
| 29 | -DBUILD_TESTING=OFF \ |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 30 | -DABSL_ENABLE_INSTALL=ON \ |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 31 | " |
| 32 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 33 | BBCLASSEXTEND = "native nativesdk" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 34 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 35 | SYSROOT_DIRS:append:class-nativesdk:mingw32 = " ${bindir}" |
| 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | FILES:${PN}-dev += "${includedir} ${libdir}/cmake ${libdir}/pkgconfig" |