Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 1 | # Copyright (C) 2021 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "A C library that may be linked into a C/C++ program to produce symbolic backtraces" |
| 5 | HOMEPAGE = "https://github.com/ianlancetaylor/libbacktrace" |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=24b5b3feec63c4be0975e1fea5100440" |
| 8 | |
| 9 | DEPENDS += "libunwind" |
| 10 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 11 | SRC_URI = "git://github.com/ianlancetaylor/libbacktrace;protocol=https;branch=master" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 12 | |
| 13 | PV = "1.0+git${SRCPV}" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 14 | SRCREV = "9ae4f4ae4481b1e69d38ed810980d33103544613" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit autotools |
| 19 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 20 | EXTRA_OECONF += "--with-system-libunwind --enable-shared --disable-static" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 21 | |
| 22 | do_configure() { |
| 23 | oe_runconf |
| 24 | } |
| 25 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 26 | # libunwind does not support RISCV32 yet |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | COMPATIBLE_HOST:riscv32 = "null" |