blob: 45b7726509cf2322c0c3f7126d9d9bb505652066 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "ExtUtils::CppGuess - guess C++ compiler and flags"
2DESCRIPTION = "ExtUtils::CppGuess attempts to guess the system's C++ \
3compiler that is compatible with the C compiler that your perl was built \
4with. \
5It can generate the necessary options to the Module::Build constructor or \
6to ExtUtils::MakeMaker's WriteMakefile function."
7SECTION = "libs"
8
9HOMEPAGE = "http://search.cpan.org/~smueller/ExtUtils-CppGuess/"
10
11LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
12LIC_FILES_CHKSUM = "file://README;beginline=81;endline=84;md5=84c0390b90ea8c6702ce659b67bed699"
13
14SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETJ/ExtUtils-CppGuess-${PV}.tar.gz"
15SRC_URI[sha256sum] = "b2c7b581901054a32dfcea12536fda8626457ed0bfbc02600bd354bde7e2a9b4"
16
17S = "${WORKDIR}/ExtUtils-CppGuess-${PV}"
18
19inherit cpan
20
21do_install () {
22 cpan_do_install
23}
24
25RDEPENDS:${PN} = " libcapture-tiny-perl \
26 perl-module-scalar-util \
27 perl-module-io-file \
28 perl-module-extutils-makemaker \
29 perl-module-file-spec \
30 perl-module-exporter \
31 perl-module-carp \
32 perl-module-file-temp \
33 perl-module-lib \
34"
35
36BBCLASSEXTEND = "native"