Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | DESCRIPTION = "libglvnd is a vendor-neutral dispatch layer for arbitrating \ |
| 2 | OpenGL API calls between multiple vendors." |
| 3 | HOMEPAGE = "https://gitlab.freedesktop.org/glvnd/libglvnd" |
| 4 | LICENSE = "MIT & BSD-1-Clause & BSD-3-Clause & GPL-3.0-with-autoconf-exception" |
| 5 | LIC_FILES_CHKSUM = "file://README.md;beginline=323;md5=7ac5f0111f648b92fe5427efeb08e8c4" |
| 6 | |
| 7 | SRC_URI = "git://git@gitlab.freedesktop.org/glvnd/libglvnd.git;protocol=https;branch=master" |
| 8 | |
| 9 | # v1.5.0 tag |
| 10 | SRCREV = "b05bbcdaeb9b700cf7877e6d66f8fc3ac952295b" |
| 11 | |
| 12 | REQUIRED_DISTRO_FEATURES = "opengl" |
| 13 | |
| 14 | inherit meson pkgconfig features_check |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | PACKAGECONFIG ?= "\ |
| 19 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \ |
| 20 | ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl gles1 gles2', '', d)} \ |
| 21 | ${@bb.utils.contains('DISTRO_FEATURES', 'opengl x11', 'glx', '', d)} \ |
| 22 | " |
| 23 | |
| 24 | PACKAGECONFIG[x11] = "-Dx11=enabled,-Dx11=disabled,libx11 libxext xorgproto" |
| 25 | PACKAGECONFIG[glx] = "-Dglx=enabled,-Dglx=disabled,libx11 libxext xorgproto" |
| 26 | PACKAGECONFIG[egl] = "-Degl=true,-Degl=false," |
| 27 | PACKAGECONFIG[gles1] = "-Dgles1=true,-Dgles1=false," |
| 28 | PACKAGECONFIG[gles2] = "-Dgles2=true,-Dgles2=false," |
| 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |