Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 1 | SUMMARY = "Easy to use CLI and C library for communicating with Microsemi's Switchtec management interface" |
| 2 | HOMEPAGE = "https://github.com/Microsemi/switchtec-user" |
| 3 | SECTION = "console/utils" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3d6b07c89629cff2990d2e8e1f4c2382" |
| 6 | |
| 7 | DEPENDS = "ncurses openssl" |
| 8 | |
| 9 | SRCREV = "762ba441d2c02685f98e5f56e984db033bab279a" |
| 10 | SRC_URI = " \ |
| 11 | git://github.com/Microsemi/switchtec-user.git;protocol=https;branch=master \ |
| 12 | file://0001-cli-Fix-format-security-warning.patch \ |
| 13 | " |
| 14 | SRC_URI[sha256sum] = "f98c1fe23e1d7a11fb23e8bcf9b563929fc805ea669191a7fd525ad16519f655" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit autotools-brokensep pkgconfig |
| 19 | |
| 20 | EXTRA_OEMAKE = "DESTDIR='${D}' PREFIX='${prefix}' LDCONFIG='true' LIBDIR='${D}${libdir}'" |
| 21 | |
| 22 | do_install () { |
| 23 | oe_runmake install |
| 24 | } |