blob: b45bd2d63e33ad743a38e9cb865ae182f8eb6bd8 [file] [log] [blame]
Andrew Geissler5082cc72023-09-11 08:41:39 -04001SUMMARY = "The implementation of SOME/IP"
2DESCRIPTION = "The vsomeip stack implements the http://some-ip.com/ \
3(Scalable service-Oriented MiddlewarE over IP (SOME/IP)) protocol."
4HOMEPAGE = "https://github.com/COVESA/vsomeip"
5SECTION = "net"
6
7LICENSE = "MPL-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=9741c346eef56131163e13b9db1241b3"
9
10SRC_URI = "git://github.com/GENIVI/${BPN}.git;branch=master;protocol=https;name=vsomeip \
11 file://0001-Fix-pkgconfig-dir-for-multilib.patch \
12 file://0002-Install-example-configuration-files-to-etc-vsomeip.patch \
13 file://0003-Do-not-build-external-gtest.patch \
14 file://0004-Do-not-specify-PIE-flag-explicitly.patch \
15 "
16
17SRCREV = "07464840f503670bc75997b8e926b54734ffa410"
18
19COMPATIBLE_HOST:mips = "null"
20COMPATIBLE_HOST:mips64 = "null"
21COMPATIBLE_HOST:powerpc = "null"
22COMPATIBLE_HOST:libc-musl = 'null'
23
24DEPENDS = "boost dlt-daemon googletest"
25
26S = "${WORKDIR}/git"
27
28inherit cmake pkgconfig
29
30EXTRA_OECMAKE = "-DINSTALL_LIB_DIR:PATH=${baselib} \
31 -DINSTALL_CMAKE_DIR:PATH=${baselib}/cmake/vsomeip3 \
32 "
33
34# For vsomeip-test
35EXTRA_OECMAKE += "-DTEST_IP_MASTER=10.0.3.1 \
36 -DTEST_IP_SLAVE=10.0.3.2 \
37 -DTEST_IP_SLAVE_SECOND=10.0.3.3 \
38 -DTEST_UID=1000 -DTEST_GID=1000 \
39 "
40
41RDEPENDS:${PN}-test = "bash lsof"
42
43do_compile:append() {
44 cmake_runcmake_build --target examples
45 cmake_runcmake_build --target build_tests
46}
47
48do_install:append() {
49 install -d ${D}/opt/${PN}-test/examples
50 install -m 0755 ${B}/examples/*-sample ${D}/opt/${PN}-test/examples
51 install -d ${D}/opt/${PN}-test/examples/routingmanagerd
52 install -m 0755 ${B}/examples/routingmanagerd/routingmanagerd \
53 ${D}/opt/${PN}-test/examples/routingmanagerd
54
55 install -d ${D}/opt/${PN}-test/test/test/common
56 cp -rf ${S}/test/common/examples_policies \
57 ${D}/opt/${PN}-test/test/test/common/
58
59 for d in unit_tests network_tests; do
60 install -d ${D}/opt/${PN}-test/test/$d
61 cp -f ${B}/test/$d/*test* ${D}/opt/${PN}-test/test/$d
62 done
63}
64
65PACKAGES += "${PN}-test"
66
67FILES:${PN}-dbg += " \
68 /opt/${PN}-test/.debug/* \
69 "
70FILES:${PN}-test = " \
71 /opt/${PN}-test \
72 "