Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | DESCRIPTION = "TENEX C Shell, an enhanced version of Berkeley csh \ |
| 2 | The TENEX C Shell is an enhanced version of the Berkeley Unix C shell. \ |
| 3 | It includes all features of 4.4BSD C shell, plus a command-line editor, \ |
| 4 | programmable word completion, spelling correction and more." |
| 5 | |
| 6 | HOMEPAGE = "http://www.tcsh.org/" |
| 7 | LICENSE = "BSD-3-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://Copyright;md5=575cf2715c3bf894e1f79aec1d4eaaf5" |
| 9 | SECTION = "base" |
| 10 | DEPENDS = "ncurses virtual/crypt gettext-native" |
| 11 | SRC_URI = " \ |
| 12 | https://astron.com/pub/${BPN}/${BP}.tar.gz \ |
| 13 | file://0001-Enable-system-malloc-on-all-linux.patch \ |
| 14 | file://0002-Add-debian-csh-scripts.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | " |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 16 | SRC_URI[sha256sum] = "13475c0fbeb74139d33ed793bf00ffbbb2ac2dc9fb1d44467a410760aba36664" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | |
| 18 | EXTRA_OEMAKE += "CC_FOR_GETHOST='${BUILD_CC}'" |
| 19 | inherit autotools |
| 20 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 21 | do_compile:prepend() { |
Patrick Williams | 0ca19cc | 2021-08-16 14:03:13 -0500 | [diff] [blame] | 22 | oe_runmake CC_FOR_GETHOST='${BUILD_CC}' CFLAGS='${BUILD_CFLAGS}' LDFLAGS='${BUILD_LDFLAGS}' gethost |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | } |
| 24 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | do_install:append () { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | oe_runmake install.man DESTDIR=${D} |
| 27 | |
| 28 | install -d ${D}${base_bindir} |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 29 | if ! ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','false',d)}; then |
| 30 | ln -s /usr/bin/tcsh ${D}${base_bindir}/tcsh |
| 31 | ln -s /usr/bin/tcsh ${D}${base_bindir}/csh |
| 32 | fi |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 33 | install -d ${D}${sysconfdir}/csh/login.d |
| 34 | install -m 0644 ${S}/csh.cshrc ${S}/csh.login ${S}/csh.logout ${S}/complete.tcsh ${D}${sysconfdir} |
| 35 | install -D -m 0644 ${S}/csh-mode.el ${D}${datadir}/emacs/site-lisp/csh-mode.el |
| 36 | } |
| 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | FILES:${PN} += "${datadir}/emacs/site-lisp/csh-mode.el" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 39 | |
| 40 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 41 | pkg_postinst:${PN} () { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 42 | #!/bin/sh -e |
| 43 | echo /usr/bin/tcsh >> $D/etc/shells |
| 44 | echo /usr/bin/csh >> $D/etc/shells |
| 45 | } |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 46 | BBCLASSEXTEND = "native nativesdk" |