Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Device Tree Compiler" |
| 2 | HOMEPAGE = "https://devicetree.org/" |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 3 | DESCRIPTION = "The Device Tree Compiler is a toolchain for working with device tree source and binary files." |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 4 | SECTION = "bootloader" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 5 | LICENSE = "GPL-2.0-only | BSD-2-Clause" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 6 | |
| 7 | LIC_FILES_CHKSUM = "file://GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 8 | file://BSD-2-Clause;md5=5d6306d1b08f8df623178dfd81880927 \ |
| 9 | file://README.license;md5=a1eb22e37f09df5b5511b8a278992d0e" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 10 | |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 11 | SRC_URI = "git://git.kernel.org/pub/scm/utils/dtc/dtc.git;branch=main;protocol=https" |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 12 | SRCREV = "039a99414e778332d8f9c04cbd3072e1dcc62798" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 13 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 14 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |
| 15 | |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 16 | S = "${WORKDIR}/git" |
| 17 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 18 | inherit meson pkgconfig |
| 19 | |
| 20 | EXTRA_OEMESON = "-Dpython=disabled -Dvalgrind=disabled" |
| 21 | |
| 22 | PACKAGECONFIG ??= "tools" |
| 23 | PACKAGECONFIG[tools] = "-Dtools=true,-Dtools=false,flex-native bison-native" |
| 24 | PACKAGECONFIG[yaml] = "-Dyaml=enabled,-Dyaml=disabled,libyaml" |
| 25 | |
| 26 | PACKAGES =+ "${PN}-misc" |
| 27 | FILES:${PN}-misc = "${bindir}/convert-dtsv0 ${bindir}/ftdump ${bindir}/dtdiff" |
| 28 | RDEPENDS:${PN}-misc += "${@bb.utils.contains('PACKAGECONFIG', 'tools', 'bash diffutils', '', d)}" |
| 29 | |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 30 | BBCLASSEXTEND = "native nativesdk" |