Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | DESCRIPTION = "gvfs is a userspace virtual filesystem" |
| 2 | LICENSE = "LGPL-2.0-only" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=05df38dd77c35ec8431f212410a3329e" |
| 4 | |
| 5 | GNOMEBASEBUILDCLASS = "meson" |
| 6 | inherit gnomebase gsettings bash-completion gettext upstream-version-is-even features_check useradd |
| 7 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 8 | DEPENDS += "\ |
| 9 | dbus \ |
| 10 | glib-2.0 \ |
| 11 | glib-2.0-native \ |
| 12 | gsettings-desktop-schemas \ |
| 13 | libgudev \ |
| 14 | libsecret \ |
| 15 | libxml2 \ |
| 16 | shadow-native \ |
| 17 | " |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 18 | |
| 19 | RDEPENDS:${PN} += "gsettings-desktop-schemas" |
| 20 | |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 21 | SRC_URI = "https://download.gnome.org/sources/${BPN}/${@gnome_verdir("${PV}")}/${BPN}-${PV}.tar.xz;name=archive" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 22 | |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 23 | SRC_URI[archive.sha256sum] = "ab9059a676a537edbea21388c2aafe1a7e2c8f1ac2dfdc6d64550233075457fd" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 24 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 25 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 26 | |
| 27 | EXTRA_OEMESON = " \ |
| 28 | -Dbluray=false \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 29 | " |
| 30 | |
| 31 | PACKAGES =+ "gvfsd-ftp gvfsd-sftp gvfsd-trash" |
| 32 | |
| 33 | FILES:${PN} += " \ |
| 34 | ${datadir}/glib-2.0 \ |
| 35 | ${datadir}/GConf \ |
| 36 | ${datadir}/dbus-1/services \ |
| 37 | ${libdir}/gio/modules/*.so \ |
| 38 | ${libdir}/tmpfiles.d \ |
| 39 | ${systemd_user_unitdir} \ |
| 40 | " |
| 41 | |
| 42 | FILES:${PN}-dbg += "${libdir}/gio/modules/.debug/*" |
| 43 | FILES:${PN}-dev += "${libdir}/gio/modules/*.la" |
| 44 | |
| 45 | FILES:gvfsd-ftp = "${libexecdir}/gvfsd-ftp ${datadir}/gvfs/mounts/ftp.mount" |
| 46 | FILES:gvfsd-sftp = "${libexecdir}/gvfsd-sftp ${datadir}/gvfs/mounts/sftp.mount" |
| 47 | FILES:gvfsd-trash = "${libexecdir}/gvfsd-trash ${datadir}/gvfs/mounts/trash.mount" |
| 48 | |
| 49 | RRECOMMENDS:gvfsd-ftp += "openssh-sftp openssh-ssh" |
| 50 | |
| 51 | PACKAGECONFIG ?= "libgphoto2 \ |
| 52 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
| 53 | ${@bb.utils.contains('DISTRO_FEATURES','polkit','udisks2','',d)} \ |
| 54 | ${@bb.utils.contains('DISTRO_FEATURES','polkit','admin','',d)} \ |
| 55 | " |
| 56 | |
| 57 | PACKAGECONFIG[udisks2] = "-Dudisks2=true, -Dudisks2=false, udisks2, udisks2" |
| 58 | PACKAGECONFIG[admin] = "-Dadmin=true, -Dadmin=false, libcap polkit" |
| 59 | PACKAGECONFIG[afc] = "-Dafc=true, -Dafc=false, libimobiledevice libplist" |
| 60 | PACKAGECONFIG[archive] = "-Darchive=true, -Darchive=false, libarchive" |
| 61 | PACKAGECONFIG[dnssd] = "-Ddnssd=true, -Ddnssd=false, avahi" |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 62 | PACKAGECONFIG[gcr] = "-Dgcr=true, -Dgcr=false, gcr3, gnome-keyring" |
| 63 | PACKAGECONFIG[gcrypt] = "-Dgcrypt=true, -Dgcrypt=false, libgcrypt" |
| 64 | PACKAGECONFIG[goa] = "-Dgoa=true, -Dgoa=false, gnome-online-accounts" |
| 65 | PACKAGECONFIG[google] = "-Dgoogle=true, -Dgoogle=false, libgdata" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 66 | PACKAGECONFIG[http] = "-Dhttp=true, -Dhttp=false, libsoup-3.0" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 67 | PACKAGECONFIG[libmtp] = "-Dmtp=true, -Dmtp=false, libmtp" |
| 68 | PACKAGECONFIG[logind] = "-Dlogind=true, -Dlogind=false, systemd" |
| 69 | PACKAGECONFIG[libgphoto2] = "-Dgphoto2=true, -Dgphoto2=false, libgphoto2" |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 70 | PACKAGECONFIG[nfs] = "-Dnfs=true, -Dnfs=false,libnfs" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 71 | PACKAGECONFIG[samba] = "-Dsmb=true, -Dsmb=false, samba" |
| 72 | PACKAGECONFIG[systemd] = "-Dsystemduserunitdir=${systemd_user_unitdir} -Dtmpfilesdir=${libdir}/tmpfiles.d, -Dsystemduserunitdir=no -Dtmpfilesdir=no, systemd" |
| 73 | |
| 74 | # needs meta-filesystems |
| 75 | PACKAGECONFIG[fuse] = "-Dfuse=true, -Dfuse=false, fuse3" |
| 76 | |
| 77 | # libcdio-paranoia recipe doesn't exist yet |
| 78 | PACKAGECONFIG[cdda] = "-Dcdda=true, -Dcdda=false, libcdio-paranoia" |
| 79 | |
| 80 | USERADD_PACKAGES = "${PN}" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 81 | USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 polkitd" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 82 | |
| 83 | do_install:append() { |
| 84 | if ${@bb.utils.contains('DISTRO_FEATURES', 'polkit', 'true', 'false', d)}; then |
| 85 | # Fix up permissions on polkit rules.d to work with rpm4 constraints |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 86 | chmod 700 ${D}${datadir}/polkit-1/rules.d |
| 87 | chown polkitd:root ${D}${datadir}/polkit-1/rules.d |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 88 | fi |
| 89 | |
| 90 | # After rebuilds (not from scracth) it can happen that the executables in |
| 91 | # libexec ar missing executable permission flag. Not sure but it came up |
| 92 | # during transition to meson. Looked into build files and logs but could |
| 93 | # not find suspicious |
| 94 | for exe in `find ${D}/${libexecdir}`; do |
| 95 | chmod +x $exe |
| 96 | done |
| 97 | } |