blob: 4830acff1db0fc13b349a8e23851667b2dab10c7 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Utility that provides userspace support for reading and writing to the i.MX fuses"
2LICENSE = "GPL-3.0-only"
3LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=a64ced9463b8c81d08335d41966e0592"
4
5GO_IMPORT = "github.com/usbarmory/crucible"
6SRC_URI = "git://${GO_IMPORT}.git;protocol=https;branch=master"
7
8GO_INSTALL = "\
9 ${GO_IMPORT}/cmd/crucible \
10 ${GO_IMPORT}/cmd/habtool \
11"
Patrick Williams520786c2023-06-25 16:20:36 -050012SRCREV = "269c90b0067e469c20b11e7fc5f4681ad5f0af7e"
Andrew Geissler517393d2023-01-13 08:55:19 -060013
14# Workaround for network access issue during compile step.
15# This needs to be fixed in the recipes buildsystem so that
16# it can be accomplished during do_fetch task.
17do_compile[network] = "1"
18
19inherit go-mod