blob: 2800be4784ffc266884da516994885d365ed43dc [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Very fast, header only, C++ logging library."
2HOMEPAGE = "https://github.com/gabime/spdlog/wiki"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6SRCREV = "ad0e89cbfb4d0c1ce4d097e134eb7be67baebb36"
7SRC_URI = "git://github.com/gabime/spdlog.git;protocol=https;branch=v1.x \
8 file://0001-Do-not-use-LFS64-functions-on-linux-musl.patch \
Patrick Williamse760df82023-05-26 11:10:49 -05009 file://fix-build-for-master-fmt.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060010 "
11
12DEPENDS += "fmt"
13
14S = "${WORKDIR}/git"
15
16BBCLASSEXTEND = "native"
17# no need to build example & tests & benchmarks on pure yocto
18EXTRA_OECMAKE += "-DSPDLOG_INSTALL=on -DSPDLOG_BUILD_SHARED=on -DSPDLOG_BUILD_EXAMPLE=off -DSPDLOG_BUILD_TESTS=off -DSPDLOG_BUILD_BENCH=off -DSPDLOG_FMT_EXTERNAL=on"
19
20inherit cmake