Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | LICENSE = "MIT" |
| 2 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 3 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 4 | MCMACHINE:virtclass-mcextend-musl = "qemux86-64" |
| 5 | MCMACHINE:virtclass-mcextend-tiny = "qemux86" |
| 6 | MCIMGTYPE:virtclass-mcextend-musl = "ext4" |
| 7 | MCIMGTYPE:virtclass-mcextend-tiny = "cpio.gz" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 8 | |
| 9 | MC_DEPLOY_DIR_IMAGE = "${TOPDIR}/tmp-mc-${MCNAME}/deploy/images/${MCMACHINE}" |
| 10 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 11 | do_install[mcdepends] += "mc::${MCNAME}:core-image-minimal:do_image_complete mc::${MCNAME}:virtual/kernel:do_deploy" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 12 | |
| 13 | do_install () { |
| 14 | install -d ${D}/var/lib/machines/${MCNAME} |
| 15 | install ${MC_DEPLOY_DIR_IMAGE}/core-image-minimal-${MCMACHINE}.${MCIMGTYPE} ${D}/var/lib/machines/${MCNAME}/core-image-minimal.${MCIMGTYPE} |
| 16 | install ${MC_DEPLOY_DIR_IMAGE}/bzImage ${D}/var/lib/machines/${MCNAME} |
| 17 | } |
| 18 | |
| 19 | python () { |
| 20 | mcname = d.getVar('MCNAME') |
| 21 | if not mcname: |
| 22 | raise bb.parse.SkipRecipe("Not a multiconfig target") |
| 23 | multiconfigs = d.getVar('BBMULTICONFIG') or "" |
| 24 | if mcname not in multiconfigs: |
| 25 | raise bb.parse.SkipRecipe("multiconfig target %s not enabled" % mcname) |
| 26 | } |
| 27 | |
| 28 | BBCLASSEXTEND = "mcextend:tiny mcextend:musl" |