blob: f03ebf447892b6d83c7e3ca790c7a85636c8289e [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The GPL Ghostscript PostScript/PDF interpreter"
2DESCRIPTION = "Ghostscript is used for PostScript/PDF preview and printing. Usually as \
3a back-end to a program such as ghostview, it can display PostScript and PDF \
4documents in an X11 environment. \
5\
6Furthermore, it can render PostScript and PDF files as graphics to be printed \
7on non-PostScript printers. Supported printers include common \
8dot-matrix, inkjet and laser models. \
9"
10HOMEPAGE = "http://www.ghostscript.com"
11SECTION = "console/utils"
12
13LICENSE = "GPL-3.0-only"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=f98ffa763e50cded76f49bce73aade16"
15
Patrick Williams520786c2023-06-25 16:20:36 -050016DEPENDS = "tiff jpeg fontconfig cups libpng freetype zlib"
Andrew Geissler517393d2023-01-13 08:55:19 -060017
18UPSTREAM_CHECK_URI = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases"
19UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
20
Patrick Williams520786c2023-06-25 16:20:36 -050021# We use a system libjpeg-turbo which has this fix
Andrew Geissler517393d2023-01-13 08:55:19 -060022CVE_CHECK_IGNORE += "CVE-2013-6629"
23
24def gs_verdir(v):
25 return "".join(v.split("."))
26
27
Patrick Williams520786c2023-06-25 16:20:36 -050028SRC_URI = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${@gs_verdir("${PV}")}/${BPN}-${PV}.tar.gz \
29 file://ghostscript-9.16-Werror-return-type.patch \
30 file://avoid-host-contamination.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060031"
32
Patrick Williamsb542dec2023-06-09 01:26:37 -050033SRC_URI[sha256sum] = "4df18a808cd4369f25e02dbcec2f133cb6d674627b2c6b1502020e58d43e32ce"
Andrew Geissler517393d2023-01-13 08:55:19 -060034
Patrick Williams520786c2023-06-25 16:20:36 -050035PACKAGECONFIG ??= ""
36PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+3"
37PACKAGECONFIG[libidn] = "--with-libidn,--without-libidn,libidn"
38PACKAGECONFIG[libpaper] = "--with-libpaper,--without-libpaper,libpaper"
Andrew Geissler517393d2023-01-13 08:55:19 -060039PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}, \
Patrick Williams520786c2023-06-25 16:20:36 -050040 --without-x, virtual/libx11 libxext libxt"
Andrew Geissler517393d2023-01-13 08:55:19 -060041
Patrick Williams520786c2023-06-25 16:20:36 -050042EXTRA_OECONF = "--with-jbig2dec \
Andrew Geissler517393d2023-01-13 08:55:19 -060043 --with-fontpath=${datadir}/fonts \
Andrew Geissler517393d2023-01-13 08:55:19 -060044 CUPSCONFIG="${STAGING_BINDIR_CROSS}/cups-config" \
Patrick Williams520786c2023-06-25 16:20:36 -050045 PKGCONFIG=pkg-config \
Andrew Geissler517393d2023-01-13 08:55:19 -060046 "
47
48EXTRA_OECONF:append:mipsarcho32 = " --with-large_color_index=0"
49
Patrick Williams520786c2023-06-25 16:20:36 -050050# Uses autoconf but not automake, can't do out-of-tree
51inherit autotools-brokensep pkgconfig
Andrew Geissler517393d2023-01-13 08:55:19 -060052
Patrick Williams520786c2023-06-25 16:20:36 -050053# Prune the source tree of libraries that we're using our packaging of, so that
54# ghostscript can't link to them. Can't prune zlib as that's needed for the
55# native tools.
56prune_sources() {
57 rm -rf ${S}/jpeg/ ${S}/libpng/ ${S}/tiff/ ${S}/expat/ ${S}/freetype/ ${S}/cups/lib
Andrew Geissler517393d2023-01-13 08:55:19 -060058}
Patrick Williams520786c2023-06-25 16:20:36 -050059do_unpack[postfuncs] += "prune_sources"
Andrew Geissler517393d2023-01-13 08:55:19 -060060
61do_install:append () {
62 mkdir -p ${D}${datadir}/ghostscript/${PV}/
63 cp -r ${S}/Resource ${D}${datadir}/ghostscript/${PV}/
64 cp -r ${S}/iccprofiles ${D}${datadir}/ghostscript/${PV}/
65}
66
Andrew Geissler517393d2023-01-13 08:55:19 -060067# ghostscript does not supports "arc"
68COMPATIBLE_HOST = "^(?!arc).*"
69
70# some entries in NVD uses gpl_ghostscript
71CVE_PRODUCT = "ghostscript gpl_ghostscript"