Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Text shaping library" |
| 2 | DESCRIPTION = "HarfBuzz is an OpenType text shaping engine." |
| 3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz" |
| 4 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz" |
| 5 | SECTION = "libs" |
| 6 | LICENSE = "MIT" |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=b98429b8e8e3c2a67cfef01e99e4893d \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 8 | file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc \ |
| 9 | " |
| 10 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 11 | SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/${BPN}-${PV}.tar.xz" |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 12 | SRC_URI[sha256sum] = "20770789749ac9ba846df33983dbda22db836c70d9f5d050cb9aa5347094a8fb" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 13 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 14 | DEPENDS += "glib-2.0-native" |
| 15 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 16 | inherit meson pkgconfig lib_package gtk-doc gobject-introspection github-releases |
| 17 | |
| 18 | GIR_MESON_ENABLE_FLAG = 'enabled' |
| 19 | GIR_MESON_DISABLE_FLAG = 'disabled' |
| 20 | GTKDOC_MESON_ENABLE_FLAG = 'enabled' |
| 21 | GTKDOC_MESON_DISABLE_FLAG = 'disabled' |
| 22 | |
| 23 | PACKAGECONFIG ??= "cairo freetype glib icu" |
| 24 | PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo" |
| 25 | PACKAGECONFIG[freetype] = "-Dfreetype=enabled,-Dfreetype=disabled,freetype" |
| 26 | PACKAGECONFIG[glib] = "-Dglib=enabled,-Dglib=disabled,glib-2.0" |
| 27 | PACKAGECONFIG[graphite] = "-Dgraphite=enabled,-Dgraphite=disabled,graphite2" |
| 28 | PACKAGECONFIG[icu] = "-Dicu=enabled,-Dicu=disabled,icu" |
| 29 | |
| 30 | PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset" |
| 31 | |
| 32 | LEAD_SONAME = "libharfbuzz.so" |
| 33 | |
| 34 | do_install:append() { |
| 35 | # If no tools are installed due to PACKAGECONFIG then this directory might |
| 36 | # still be installed, so remove it to stop packaging warnings. |
| 37 | [ ! -d ${D}${bindir} ] || rmdir --ignore-fail-on-non-empty ${D}${bindir} |
| 38 | } |
| 39 | |
| 40 | FILES:${PN}-icu = "${libdir}/libharfbuzz-icu.so.*" |
| 41 | FILES:${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \ |
| 42 | ${libdir}/libharfbuzz-icu.so \ |
| 43 | ${libdir}/pkgconfig/harfbuzz-icu.pc \ |
| 44 | " |
| 45 | FILES:${PN}-subset = "${libdir}/libharfbuzz-subset.so.*" |
| 46 | |
| 47 | BBCLASSEXTEND = "native nativesdk" |