blob: 14e1ca9fe1ce4eee6f34475c9a41761cde49459e [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Grilo is a framework forsearching media content from various sources"
2LICENSE = "LGPL-2.1-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4
5DEPENDS = " \
6 libxml2 \
7 glib-2.0 \
8"
9
Andrew Geissler517393d2023-01-13 08:55:19 -060010
11inherit gnomebase gobject-introspection gtk-doc gettext vala
12
Patrick Williamse760df82023-05-26 11:10:49 -050013SRC_URI[archive.sha256sum] = "884580e8c5ece280df23aa63ff5234b7d48988a404df7d6bfccd1e77b473bd96"
Andrew Geissler517393d2023-01-13 08:55:19 -060014
15GIR_MESON_OPTION = "enable-introspection"
16GTKDOC_MESON_OPTION = "enable-gtk-doc"
17
18# Note: removing 'net' from PACKAGECONFIG causes
19# | bindings/vala/meson.build:15:0: ERROR: Unknown variable "grlnet_gir".
20PACKAGECONFIG ??= "net"
21
22PACKAGECONFIG[net] = "-Denable-grl-net=true, -Denable-grl-net=false, libsoup-3.0"
23PACKAGECONFIG[test-ui] = "-Denable-test-ui=true, -Denable-test-ui=false, gtk+3 liboauth"
24
25# Once we have a recipe for 'totem-plparser' this can turn into a PACKAGECONFIG
26EXTRA_OEMESON = "-Denable-grl-pls=false"
27
Patrick Williams8e7b46e2023-05-01 14:19:06 -050028do_compile:append() {
29 sed -i -e 's,${B}/../,,' ${B}/src/grl-type-builtins.h
30}