Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 1 | require ${BPN}.inc |
| 2 | |
| 3 | DEPENDS = " \ |
| 4 | ${BPN}-native intltool-native gperf-native \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 5 | glib-2.0 gtk+3 libgdata libxml2 icu \ |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 6 | dbus db virtual/libiconv zlib libsoup-2.4 libical nss libsecret \ |
| 7 | " |
| 8 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 9 | inherit pkgconfig gsettings gobject-introspection features_check cmake gtk-doc gettext perlnative vala |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 10 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 11 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 12 | |
| 13 | SRC_URI += " \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 14 | file://0001-cmake-Do-not-export-CC-into-gir-compiler.patch \ |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 15 | file://0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch \ |
| 16 | file://0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch \ |
| 17 | file://0003-contact-Replace-the-Novell-sample-contact-with-somet.patch \ |
| 18 | file://0004-call-native-helpers.patch \ |
| 19 | file://iconv-detect.h \ |
| 20 | " |
| 21 | |
| 22 | LKSTRFTIME = "HAVE_LKSTRFTIME=ON" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | LKSTRFTIME:libc-musl = "HAVE_LKSTRFTIME=OFF" |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 24 | |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 25 | EXTRA_OECMAKE = " \ |
| 26 | -DSYSCONF_INSTALL_DIR=${sysconfdir} \ |
| 27 | -DWITH_KRB5=OFF \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 28 | -DENABLE_GOA=OFF \ |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 29 | -DENABLE_GOOGLE_AUTH=OFF \ |
| 30 | -DENABLE_WEATHER=OFF \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 31 | -DVAPIGEN=${STAGING_BINDIR_NATIVE}/vapigen \ |
| 32 | ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON -DENABLE_VALA_BINDINGS=ON', '-DENABLE_INTROSPECTION=OFF', d)} \ |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 33 | -D${LKSTRFTIME} \ |
| 34 | -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \ |
| 35 | " |
| 36 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 37 | EXTRA_OECMAKE:append:class-target = " -DG_IR_COMPILER=${STAGING_BINDIR}/g-ir-compiler-wrapper" |
| 38 | EXTRA_OECMAKE:append:class-target = " -DG_IR_SCANNER=${STAGING_BINDIR}/g-ir-scanner-wrapper" |
| 39 | |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 40 | PACKAGECONFIG[canberra] = "-DENABLE_CANBERRA=ON,-DENABLE_CANBERRA=OFF,libcanberra" |
| 41 | PACKAGECONFIG[oauth] = "-DENABLE_OAUTH2=ON,-DENABLE_OAUTH2=OFF,webkitgtk json-glib" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 42 | PACKAGECONFIG[goa] = "-DENABLE_GOA=ON,-DENABLE_GOA=OFF,gnome-online-accounts" |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 43 | |
| 44 | # BROKEN: due missing pkg-config in openldap eds' cmake finds host-libs when |
| 45 | # searching for openldap-libs |
| 46 | PACKAGECONFIG[openldap] = "-DWITH_OPENLDAP=ON,-DWITH_OPENLDAP=OFF,openldap" |
| 47 | |
| 48 | # -ldb needs this on some platforms |
| 49 | LDFLAGS += "-lpthread -lgmodule-2.0 -lgthread-2.0" |
| 50 | |
Patrick Williams | 5877637 | 2022-04-13 09:07:35 -0500 | [diff] [blame] | 51 | # invokes libraries from build host |
| 52 | GI_DATA_ENABLED:libc-musl="False" |
| 53 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 54 | do_configure:append () { |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 55 | cp ${WORKDIR}/iconv-detect.h ${S}/src |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 56 | # avoid writing perl-native path into csv2vcard shebang |
| 57 | sed -i "s|@PERL@|${bindir}/perl|" ${S}/src/tools/addressbook-export/csv2vcard.in |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 58 | } |
| 59 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 60 | FILES:${PN} =+ " \ |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 61 | ${datadir}/dbus-1 \ |
| 62 | ${datadir}/evolution-data-server-*/ui/ \ |
| 63 | ${systemd_user_unitdir} \ |
| 64 | " |
| 65 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 66 | RDEPENDS:${PN} += "perl" |