Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "GNOME session" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 2 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 4 | |
| 5 | DEPENDS = " \ |
| 6 | glib-2.0-native \ |
| 7 | libxslt-native \ |
| 8 | xmlto-native \ |
| 9 | xtrans \ |
| 10 | libice \ |
| 11 | libsm \ |
| 12 | virtual/libx11 \ |
| 13 | gtk+3 \ |
| 14 | gnome-desktop \ |
| 15 | gsettings-desktop-schemas \ |
| 16 | json-glib \ |
| 17 | " |
| 18 | |
| 19 | GNOMEBASEBUILDCLASS = "meson" |
| 20 | |
| 21 | inherit gnomebase gettext gsettings upstream-version-is-even features_check |
| 22 | |
| 23 | REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam gobject-introspection-data" |
| 24 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 25 | SRC_URI[archive.sha256sum] = "3cca06053ab682926920951a7da95f8cc6d72da74c682c46d0a0653332969caa" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 26 | |
| 27 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', 'consolekit',d)}" |
| 28 | |
| 29 | PACKAGECONFIG[consolekit] = "-Dconsolekit=true, -Dconsolekit=false, consolekit" |
| 30 | PACKAGECONFIG[systemd] = "-Dsystemd=true -Dsystemd_journal=true, -Dsystemd=false -Dsystemd_journal=false, systemd" |
| 31 | |
| 32 | FILES:${PN} += " \ |
| 33 | ${datadir}/xsessions \ |
| 34 | ${datadir}/wayland-sessions \ |
| 35 | ${systemd_user_unitdir} \ |
| 36 | " |
| 37 | |
| 38 | RDEPENDS:${PN} += "gnome-shell gnome-settings-daemon gsettings-desktop-schemas" |