Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "System-wide Performance Profiler for Linux" |
| 2 | HOMEPAGE = "http://www.sysprof.com" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 3 | LICENSE = "GPL-3.0-or-later" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ |
| 5 | file://src/sysprof/sysprof-application.c;endline=17;md5=a3de8df3b0f8876dd01e1388d2d4b607" |
| 6 | |
| 7 | GNOMEBASEBUILDCLASS = "meson" |
| 8 | inherit gnomebase gnome-help gettext systemd upstream-version-is-even gsettings mime mime-xdg |
| 9 | |
| 10 | DEPENDS += " \ |
| 11 | glib-2.0-native \ |
| 12 | yelp-tools-native \ |
| 13 | libxml2-native \ |
| 14 | glib-2.0 \ |
| 15 | json-glib \ |
| 16 | " |
| 17 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 18 | SRC_URI += "file://0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch" |
| 19 | SRC_URI[archive.sha256sum] = "ab5d9f5b71973b3088d58a1bfdf1dc23c39a02f5fce4e5e9c73e034b178b005b" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 20 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 21 | PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'polkit', 'sysprofd libsysprof', '', d)} \ |
| 22 | ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)} \ |
| 23 | libunwind" |
| 24 | # nongnu libunwind needs porting to RV32 |
| 25 | PACKAGECONFIG:remove:riscv32 = "libunwind" |
| 26 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 27 | PACKAGECONFIG[gtk] = "-Denable_gtk=true,-Denable_gtk=false,gtk+3 libdazzle" |
| 28 | PACKAGECONFIG[sysprofd] = "-Dwith_sysprofd=bundled,-Dwith_sysprofd=none,polkit" |
| 29 | PACKAGECONFIG[libsysprof] = "-Dlibsysprof=true,-Dlibsysprof=false,polkit" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 30 | PACKAGECONFIG[libunwind] = "-Dlibunwind=true,-Dlibunwind=false,libunwind" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 31 | |
| 32 | EXTRA_OEMESON += "-Dsystemdunitdir=${systemd_unitdir}/system" |
| 33 | |
| 34 | SOLIBS = ".so" |
| 35 | FILES_SOLIBSDEV = "" |
| 36 | |
| 37 | SYSTEMD_SERVICE:${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'sysprofd', 'sysprof2.service sysprof3.service', '', d)}" |
| 38 | |
| 39 | FILES:${PN} += " \ |
| 40 | ${datadir}/dbus-1/system-services \ |
| 41 | ${datadir}/dbus-1/system.d \ |
| 42 | ${datadir}/dbus-1/interfaces \ |
| 43 | ${datadir}/metainfo \ |
| 44 | " |