Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # |
| 2 | # This is for perl modules that use the old Makefile.PL build system |
| 3 | # |
| 4 | inherit cpan-base perlnative |
| 5 | |
| 6 | EXTRA_CPANFLAGS ?= "" |
| 7 | EXTRA_PERLFLAGS ?= "" |
| 8 | |
| 9 | # Env var which tells perl if it should use host (no) or target (yes) settings |
| 10 | export PERLCONFIGTARGET = "${@is_target(d)}" |
| 11 | |
| 12 | # Env var which tells perl where the perl include files are |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | export PERL_INC = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl5/${@get_perl_version(d)}/${@get_perl_arch(d)}/CORE" |
| 14 | export PERL_LIB = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl5/${@get_perl_version(d)}" |
| 15 | export PERL_ARCHLIB = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl5/${@get_perl_version(d)}/${@get_perl_arch(d)}" |
| 16 | export PERLHOSTLIB = "${STAGING_LIBDIR_NATIVE}/perl5/${@get_perl_version(d)}/" |
| 17 | export PERLHOSTARCHLIB = "${STAGING_LIBDIR_NATIVE}/perl5/${@get_perl_version(d)}/${@get_perl_hostarch(d)}/" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | |
| 19 | cpan_do_configure () { |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 20 | yes '' | perl ${EXTRA_PERLFLAGS} Makefile.PL INSTALLDIRS=vendor NO_PERLLOCAL=1 NO_PACKLIST=1 PERL=$(which perl) ${EXTRA_CPANFLAGS} |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 21 | |
| 22 | # Makefile.PLs can exit with success without generating a |
| 23 | # Makefile, e.g. in cases of missing configure time |
| 24 | # dependencies. This is considered a best practice by |
| 25 | # cpantesters.org. See: |
| 26 | # * http://wiki.cpantesters.org/wiki/CPANAuthorNotes |
| 27 | # * http://www.nntp.perl.org/group/perl.qa/2008/08/msg11236.html |
| 28 | [ -e Makefile ] || bbfatal "No Makefile was generated by Makefile.PL" |
| 29 | |
| 30 | if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 31 | . ${STAGING_LIBDIR}${PERL_OWN_DIR}/perl5/config.sh |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 32 | # Use find since there can be a Makefile generated for each Makefile.PL |
| 33 | for f in `find -name Makefile.PL`; do |
| 34 | f2=`echo $f | sed -e 's/.PL//'` |
| 35 | test -f $f2 || continue |
| 36 | sed -i -e "s:\(PERL_ARCHLIB = \).*:\1${PERL_ARCHLIB}:" \ |
| 37 | -e 's/perl.real/perl/' \ |
| 38 | -e "s|^\(CCFLAGS =.*\)|\1 ${CFLAGS}|" \ |
| 39 | $f2 |
| 40 | done |
| 41 | fi |
| 42 | } |
| 43 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 44 | do_configure_append_class-target() { |
| 45 | find . -name Makefile | xargs sed -E -i \ |
| 46 | -e 's:LD_RUN_PATH ?= ?"?[^"]*"?::g' |
| 47 | } |
| 48 | |
| 49 | do_configure_append_class-nativesdk() { |
| 50 | find . -name Makefile | xargs sed -E -i \ |
| 51 | -e 's:LD_RUN_PATH ?= ?"?[^"]*"?::g' |
| 52 | } |
| 53 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 54 | cpan_do_compile () { |
| 55 | oe_runmake PASTHRU_INC="${CFLAGS}" LD="${CCLD}" |
| 56 | } |
| 57 | |
| 58 | cpan_do_install () { |
| 59 | oe_runmake DESTDIR="${D}" install_vendor |
| 60 | for PERLSCRIPT in `grep -rIEl '#! *${bindir}/perl-native.*/perl' ${D}`; do |
| 61 | sed -i -e 's|${bindir}/perl-native.*/perl|/usr/bin/env nativeperl|' $PERLSCRIPT |
| 62 | done |
| 63 | } |
| 64 | |
| 65 | EXPORT_FUNCTIONS do_configure do_compile do_install |