Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "msmtp is an SMTP client" |
| 2 | DESCRIPTION = "A sendmail replacement for use in MTAs like mutt" |
| 3 | HOMEPAGE = "http://msmtp.sourceforge.net/" |
| 4 | SECTION = "console/network" |
| 5 | |
| 6 | LICENSE = "GPLv3" |
| 7 | DEPENDS = "zlib gnutls" |
| 8 | |
| 9 | #COPYING or Licence |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 11 | |
| 12 | SRC_URI = "http://sourceforge.net/projects/msmtp/files/msmtp/${PV}/${BPN}-${PV}.tar.xz \ |
| 13 | " |
| 14 | |
| 15 | SRC_URI[md5sum] = "6d9384c09405db9476beaa2237c56705" |
| 16 | SRC_URI[sha256sum] = "f982be069c0772c3ee83925f552f5dac5fb307d2d1c68202f9926bb13b757355" |
| 17 | |
| 18 | inherit gettext autotools update-alternatives pkgconfig |
| 19 | |
| 20 | EXTRA_OECONF += "--without-libsecret --without-libgsasl --without-libidn" |
| 21 | |
| 22 | ALTERNATIVE_${PN} = "sendmail" |
| 23 | ALTERNATIVE_TARGET[sendmail] = "${bindir}/msmtp" |
| 24 | ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail" |
| 25 | ALTERNATIVE_PRIORITY = "100" |
| 26 | |
| 27 | pkg_postinst_${PN}_linuxstdbase () { |
| 28 | # /usr/lib/sendmial is required by LSB core test |
| 29 | [ ! -L $D/usr/lib/sendmail ] && ln -sf ${sbindir}/sendmail $D/usr/lib/ |
| 30 | } |