Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # Version 5 of the Berkeley DB from Sleepycat |
| 2 | # |
| 3 | # At present this package only installs the DB code |
| 4 | # itself (shared libraries, .a in the dev package), |
| 5 | # documentation and headers. |
| 6 | # |
| 7 | # The headers have the same names as those as v3 |
| 8 | # of the DB, only one version can be used *for dev* |
| 9 | # at once - DB3 and DB5 can both be installed on the |
| 10 | # same system at the same time if really necessary. |
| 11 | SECTION = "libs" |
| 12 | SUMMARY = "Berkeley Database v5" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 13 | HOMEPAGE = "http://www.oracle.com/technetwork/database/database-technologies/berkeleydb/overview/index.html" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | LICENSE = "Sleepycat" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 15 | RCONFLICTS_${PN} = "db3" |
| 16 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 17 | CVE_PRODUCT = "oracle_berkeley_db" |
| 18 | CVE_VERSION = "11.2.${PV}" |
| 19 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 20 | PR = "r1" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 21 | PE = "1" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 22 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 23 | SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | SRC_URI += "file://fix-parallel-build.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 25 | file://0001-atomic-Rename-local-__atomic_compare_exchange-to-avo.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 26 | file://0001-configure-Add-explicit-tag-options-to-libtool-invoca.patch \ |
| 27 | file://sequence-type.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 28 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 29 | # We are not interested in official latest 6.x versions; |
| 30 | # let's track what debian is using. |
| 31 | UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/db5.3/" |
| 32 | UPSTREAM_CHECK_REGEX = "db5\.3_(?P<pver>.+)\.orig" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 33 | |
| 34 | SRC_URI[md5sum] = "b99454564d5b4479750567031d66fe24" |
| 35 | SRC_URI[sha256sum] = "e0a992d740709892e81f9d93f06daf305cf73fb81b545afe72478043172c3628" |
| 36 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 37 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ed1158e31437f4f87cdd4ab2b8613955" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 38 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 39 | inherit autotools |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 40 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 41 | # The executables go in a separate package - typically there |
| 42 | # is no need to install these unless doing real database |
| 43 | # management on the system. |
| 44 | inherit lib_package |
| 45 | |
| 46 | PACKAGES =+ "${PN}-cxx" |
| 47 | FILES_${PN}-cxx = "${libdir}/*cxx*so" |
| 48 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 49 | # The dev package has the .so link (as in db3) and the .a's - |
| 50 | # it is therefore incompatible (cannot be installed at the |
| 51 | # same time) as the db3 package |
| 52 | # sort out the .so since they do version prior to the .so |
| 53 | SOLIBS = "-5*.so" |
| 54 | FILES_SOLIBSDEV = "${libdir}/libdb.so ${libdir}/libdb_cxx.so" |
| 55 | |
| 56 | #configuration - set in local.conf to override |
| 57 | # All the --disable-* options replace --enable-smallbuild, which breaks a bunch of stuff (eg. postfix) |
| 58 | DB5_CONFIG ?= "--enable-o_direct --disable-cryptography --disable-queue --disable-replication --disable-verify --disable-compat185 --disable-sql" |
| 59 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 60 | EXTRA_OECONF = "${DB5_CONFIG} --enable-shared --enable-cxx --with-sysroot STRIP=true" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 61 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 62 | EXTRA_OEMAKE += "LIBTOOL='./${HOST_SYS}-libtool'" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 63 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 64 | EXTRA_AUTORECONF += "--exclude=autoheader -I ${S}/dist/aclocal -I${S}/dist/aclocal_java" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 65 | AUTOTOOLS_SCRIPT_PATH = "${S}/dist" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 66 | |
| 67 | # Cancel the site stuff - it's set for db3 and destroys the |
| 68 | # configure. |
| 69 | CONFIG_SITE = "" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 70 | |
| 71 | oe_runconf_prepend() { |
| 72 | . ${S}/dist/RELEASE |
| 73 | # Edit version information we couldn't pre-compute. |
| 74 | sed -i -e "s/__EDIT_DB_VERSION_FAMILY__/$DB_VERSION_FAMILY/g" \ |
| 75 | -e "s/__EDIT_DB_VERSION_RELEASE__/$DB_VERSION_RELEASE/g" \ |
| 76 | -e "s/__EDIT_DB_VERSION_MAJOR__/$DB_VERSION_MAJOR/g" \ |
| 77 | -e "s/__EDIT_DB_VERSION_MINOR__/$DB_VERSION_MINOR/g" \ |
| 78 | -e "s/__EDIT_DB_VERSION_PATCH__/$DB_VERSION_PATCH/g" \ |
| 79 | -e "s/__EDIT_DB_VERSION_STRING__/$DB_VERSION_STRING/g" \ |
| 80 | -e "s/__EDIT_DB_VERSION_FULL_STRING__/$DB_VERSION_FULL_STRING/g" \ |
| 81 | -e "s/__EDIT_DB_VERSION_UNIQUE_NAME__/$DB_VERSION_UNIQUE_NAME/g" \ |
| 82 | -e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" ${S}/dist/configure |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 83 | } |
| 84 | |
| 85 | do_compile_prepend() { |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 86 | # Stop libtool adding RPATHs |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 87 | sed -i -e 's|hardcode_into_libs=yes|hardcode_into_libs=no|' ${B}/${HOST_SYS}-libtool |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 88 | } |
| 89 | |
| 90 | do_install_append() { |
| 91 | mkdir -p ${D}/${includedir}/db51 |
| 92 | mv ${D}/${includedir}/db.h ${D}/${includedir}/db51/. |
| 93 | mv ${D}/${includedir}/db_cxx.h ${D}/${includedir}/db51/. |
| 94 | ln -s db51/db.h ${D}/${includedir}/db.h |
| 95 | ln -s db51/db_cxx.h ${D}/${includedir}/db_cxx.h |
| 96 | |
| 97 | # The docs end up in /usr/docs - not right. |
| 98 | if test -d "${D}/${prefix}/docs" |
| 99 | then |
| 100 | mkdir -p "${D}/${datadir}" |
| 101 | test ! -d "${D}/${docdir}" || rm -rf "${D}/${docdir}" |
| 102 | mv "${D}/${prefix}/docs" "${D}/${docdir}" |
| 103 | fi |
| 104 | |
| 105 | chown -R root:root ${D} |
| 106 | } |
| 107 | |
| 108 | INSANE_SKIP_${PN} = "dev-so" |
| 109 | INSANE_SKIP_${PN}-cxx = "dev-so" |
| 110 | |
| 111 | BBCLASSEXTEND = "native nativesdk" |