blob: 01eb14b9fb0d5308f5c875de3875c91abbfbb480 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Vulkan Header files and API registry"
2DESCRIPTION = "Vulkan is a 3D graphics and compute API providing cross-platform access \
3to modern GPUs with low overhead and targeting realtime graphics applications such as \
4games and interactive media. This package contains the development headers \
5for packages wanting to make use of Vulkan."
6HOMEPAGE = "https://www.khronos.org/vulkan/"
7BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Headers"
8SECTION = "libs"
9
Andrew Geissler220dafd2023-10-04 10:18:08 -050010LICENSE = "Apache-2.0 & MIT"
11LIC_FILES_CHKSUM = "file://LICENSE.md;md5=1bc355d8c4196f774c8b87ed1a8dd625"
Andrew Geissler517393d2023-01-13 08:55:19 -060012SRC_URI = "git://github.com/KhronosGroup/Vulkan-Headers.git;branch=main;protocol=https"
13
Andrew Geissler220dafd2023-10-04 10:18:08 -050014SRCREV = "85c2334e92e215cce34e8e0ed8b2dce4700f4a50"
Andrew Geissler517393d2023-01-13 08:55:19 -060015
16S = "${WORKDIR}/git"
17
18inherit cmake
19
20FILES:${PN} += "${datadir}/vulkan"
Patrick Williams864cc432023-02-09 14:54:44 -060021RDEPENDS:${PN} += "python3-core"
Andrew Geissler517393d2023-01-13 08:55:19 -060022
Andrew Geissler028142b2023-05-05 11:29:21 -050023# These recipes need to be updated in lockstep with each other:
24# glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools
25# The tags versions should always be sdk-x.y.z, as this is what
26# upstream considers a release.
Andrew Geissler517393d2023-01-13 08:55:19 -060027UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"