Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | # Copyright (C) 2017 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | DESCRIPTION = "Lightweight cross platform C++ GUID/UUID library" |
| 5 | HOMEPAGE = "https://github.com/graeme-hill/crossguid" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1373274bc8d8001edc54933919f36f68" |
| 8 | DEPENDS += "util-linux" |
| 9 | |
| 10 | PV = "0.0+git${SRCPV}" |
| 11 | |
| 12 | SRCREV = "b56957ac453575e91ca1b63a80c0077c2b0d011a" |
| 13 | SRC_URI = "git://github.com/graeme-hill/crossguid;protocol=https" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | do_compile() { |
| 18 | ${CXX} -c guid.cpp -o guid.o ${CXXFLAGS} -std=c++11 -DGUID_LIBUUID |
| 19 | ${AR} rvs libcrossguid.a guid.o |
| 20 | } |
| 21 | |
| 22 | do_install() { |
| 23 | install -D -m 0644 ${B}/libcrossguid.a ${D}${libdir}/libcrossguid.a |
| 24 | install -D -m 0644 ${S}/guid.h ${D}${includedir}/guid.h |
| 25 | } |