Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "File type identification using libmagic" |
| 2 | DESCRIPTION = "This module uses ctypes to access the libmagic file type \ |
| 3 | identification library. It makes use of the local magic database and supports \ |
| 4 | both textual and MIME-type output." |
| 5 | HOMEPAGE = "http://github.com/ahupp/python-magic" |
| 6 | |
| 7 | LICENSE = "MIT" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=61495c152d794e6be5799a9edca149e3" |
| 9 | |
| 10 | PYPI_PACKAGE = "python-magic" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 11 | |
| 12 | inherit pypi setuptools3 |
| 13 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame^] | 14 | SRC_URI[sha256sum] = "c1ba14b08e4a5f5c31a302b7721239695b2f0f058d125bd5ce1ee36b9d9d3c3b" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 15 | |
| 16 | RDEPENDS:${PN} += "file \ |
| 17 | ${PYTHON_PN}-ctypes \ |
| 18 | ${PYTHON_PN}-io \ |
| 19 | ${PYTHON_PN}-logging \ |
| 20 | ${PYTHON_PN}-shell" |
| 21 | |
| 22 | BBCLASSEXTEND = "native" |