Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame^] | 1 | SUMMARY = "Sato icon theme" |
| 2 | HOMEPAGE = "https://www.yoctoproject.org/" |
| 3 | BUGTRACKER = "http://bugzilla.yoctoproject.org/" |
| 4 | |
| 5 | LICENSE = "CC-BY-SA-3.0" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=56a830bbe6e4697fe6cbbae01bb7c2b2" |
| 7 | SECTION = "x11" |
| 8 | |
| 9 | DEPENDS = "icon-naming-utils-native libxml-simple-perl-native" |
| 10 | |
| 11 | SRC_URI = "git://git.yoctoproject.org/sato-icon-theme.git;protocol=https;branch=master" |
| 12 | SRCREV = "d23f04ecb0328f655bf195df8eb04c1b734d53a9" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit autotools pkgconfig allarch gtk-icon-cache perlnative |
| 17 | |
| 18 | # The configure script uses pkg-config to find native binaries to execute, so |
| 19 | # tell it to use our pkg-config-native wrapper. |
| 20 | export PKG_CONFIG = "pkg-config-native" |
| 21 | |
| 22 | FILES:${PN} += "${datadir}/icons/Sato" |
| 23 | |
| 24 | do_install:append() { |
| 25 | find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s preferences-system.png {}/apps/preferences-desktop.png \; |
| 26 | find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s file-manager.png {}/apps/system-file-manager.png \; |
| 27 | find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s ../apps/terminal.png {}/places/computer.png \; |
| 28 | } |