Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "The PCRE library is a set of functions that implement regular \ |
| 2 | expression pattern matching using the same syntax and semantics as Perl 5. PCRE \ |
| 3 | has its own native API, as well as a set of wrapper functions that correspond \ |
| 4 | to the POSIX regular expression API." |
| 5 | SUMMARY = "Perl Compatible Regular Expressions" |
| 6 | HOMEPAGE = "http://www.pcre.org" |
| 7 | SECTION = "devel" |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 8 | LICENSE = "BSD-3-Clause" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://LICENCE;md5=91bee59d1b327eb1599b4c673e2fb3d1" |
| 10 | SRC_URI = "https://ftp.pcre.org/pub/pcre/pcre-${PV}.tar.bz2 \ |
| 11 | file://fix-pcre-name-collision.patch \ |
| 12 | file://out-of-tree.patch \ |
| 13 | file://run-ptest \ |
| 14 | file://Makefile \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[md5sum] = "636222e79e392c3d95dcc545f24f98c4" |
| 18 | SRC_URI[sha256sum] = "91e762520003013834ac1adb4a938d53b22a216341c061b0cf05603b290faf6b" |
| 19 | |
| 20 | CVE_PRODUCT = "pcre" |
| 21 | |
| 22 | S = "${WORKDIR}/pcre-${PV}" |
| 23 | |
| 24 | PROVIDES += "pcre" |
| 25 | DEPENDS += "bzip2 zlib" |
| 26 | |
| 27 | PACKAGECONFIG ??= "pcre8 unicode-properties jit" |
| 28 | |
| 29 | PACKAGECONFIG[pcre8] = "--enable-pcre8,--disable-pcre8" |
| 30 | PACKAGECONFIG[pcre16] = "--enable-pcre16,--disable-pcre16" |
| 31 | PACKAGECONFIG[pcre32] = "--enable-pcre32,--disable-pcre32" |
| 32 | PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline," |
| 33 | PACKAGECONFIG[unicode-properties] = "--enable-unicode-properties,--disable-unicode-properties" |
| 34 | PACKAGECONFIG[jit] = "--enable-jit=auto,--disable-jit" |
| 35 | |
| 36 | BINCONFIG = "${bindir}/pcre-config" |
| 37 | |
| 38 | inherit autotools binconfig-disabled ptest |
| 39 | |
| 40 | EXTRA_OECONF = "--enable-utf" |
| 41 | |
| 42 | PACKAGES =+ "libpcrecpp libpcreposix pcregrep pcregrep-doc pcretest pcretest-doc" |
| 43 | |
| 44 | SUMMARY_libpcrecpp = "${SUMMARY} - C++ wrapper functions" |
| 45 | SUMMARY_libpcreposix = "${SUMMARY} - C wrapper functions based on the POSIX regex API" |
| 46 | SUMMARY_pcregrep = "grep utility that uses perl 5 compatible regexes" |
| 47 | SUMMARY_pcregrep-doc = "grep utility that uses perl 5 compatible regexes - docs" |
| 48 | SUMMARY_pcretest = "program for testing Perl-comatible regular expressions" |
| 49 | SUMMARY_pcretest-doc = "program for testing Perl-comatible regular expressions - docs" |
| 50 | |
| 51 | FILES_libpcrecpp = "${libdir}/libpcrecpp.so.*" |
| 52 | FILES_libpcreposix = "${libdir}/libpcreposix.so.*" |
| 53 | FILES_pcregrep = "${bindir}/pcregrep" |
| 54 | FILES_pcregrep-doc = "${mandir}/man1/pcregrep.1" |
| 55 | FILES_pcretest = "${bindir}/pcretest" |
| 56 | FILES_pcretest-doc = "${mandir}/man1/pcretest.1" |
| 57 | |
| 58 | BBCLASSEXTEND = "native nativesdk" |
| 59 | |
| 60 | do_install_ptest() { |
| 61 | t=${D}${PTEST_PATH} |
| 62 | cp ${WORKDIR}/Makefile $t |
| 63 | cp -r ${S}/testdata $t |
| 64 | for i in pcre_stringpiece_unittest pcregrep pcretest; \ |
| 65 | do cp ${B}/.libs/$i $t; \ |
| 66 | done |
| 67 | for i in RunTest RunGrepTest test-driver; \ |
| 68 | do cp ${S}/$i $t; \ |
| 69 | done |
| 70 | # Skip the fr_FR locale test. If the locale fr_FR is found, it is tested. |
| 71 | # If not found, the test is skipped. The test program assumes fr_FR is non-UTF-8 |
| 72 | # locale so the test fails if fr_FR is UTF-8 locale. |
| 73 | sed -i -e 's:do3=yes:do3=no:g' ${D}${PTEST_PATH}/RunTest |
| 74 | } |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 75 | |
| 76 | RDEPENDS_${PN}-ptest += "make" |