Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "An HTTP library implementation in C" |
| 2 | HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup" |
| 3 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 4 | SECTION = "x11/gnome/libs" |
| 5 | LICENSE = "LGPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 7 | |
| 8 | DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native libpsl" |
| 9 | |
| 10 | SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" |
| 11 | |
| 12 | SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz \ |
| 13 | file://0001-Do-not-enforce-no-introspection-when-cross-building.patch \ |
| 14 | " |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 15 | SRC_URI[md5sum] = "42016d80ecae4cf8eb416631049a273a" |
| 16 | SRC_URI[sha256sum] = "8308984f1eee1c4f8c113a9c1763b2b22d981bd811b0cc82a9f3f1aa63228779" |
| 17 | |
| 18 | CVE_PRODUCT = "libsoup" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 19 | |
| 20 | S = "${WORKDIR}/libsoup-${PV}" |
| 21 | |
| 22 | inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc |
| 23 | |
| 24 | # libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default. |
| 25 | PACKAGECONFIG ??= "" |
| 26 | PACKAGECONFIG[gnome] = "-Dgnome=true,-Dgnome=false" |
| 27 | PACKAGECONFIG[gssapi] = "-Dgssapi=true,-Dgssapi=false,krb5" |
| 28 | |
| 29 | EXTRA_OEMESON_append = " -Dvapi=false" |
| 30 | |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 31 | GTKDOC_MESON_OPTION = "gtk_doc" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 32 | |
| 33 | # When built without gnome support, libsoup-2.4 will contain only one shared lib |
| 34 | # and will therefore become subject to renaming by debian.bbclass. Prevent |
| 35 | # renaming in order to keep the package name consistent regardless of whether |
| 36 | # gnome support is enabled or disabled. |
| 37 | DEBIAN_NOAUTONAME_${PN} = "1" |
| 38 | |
| 39 | # glib-networking is needed for SSL, proxies, etc. |
| 40 | RRECOMMENDS_${PN} = "glib-networking" |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 41 | |
| 42 | BBCLASSEXTEND = "native" |