blob: 44496164b6908f8eb0f1a4b0c428d2716184703f [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001require optee-os_3.22.0.bb
2
3SUMMARY = "OP-TEE Trusted OS TA devkit"
4DESCRIPTION = "OP-TEE TA devkit for build TAs"
5HOMEPAGE = "https://www.op-tee.org/"
6
7DEPENDS += "python3-pycryptodome-native"
8
9do_install() {
10 #install TA devkit
11 install -d ${D}${includedir}/optee/export-user_ta/
12 for f in ${B}/export-ta_${OPTEE_ARCH}/* ; do
13 cp -aR $f ${D}${includedir}/optee/export-user_ta/
14 done
15}
16
17do_deploy() {
18 echo "Do not inherit do_deploy from optee-os."
19}
20
21FILES:${PN} = "${includedir}/optee/"
22
23# Build paths are currently embedded
24INSANE_SKIP:${PN}-dev += "buildpaths"
25
26# Include extra headers needed by SPMC tests to TA DEVKIT.
27# Supported after op-tee v3.20
28EXTRA_OEMAKE:append = "${@bb.utils.contains('MACHINE_FEATURES', 'optee-spmc-test', \
29 ' CFG_SPMC_TESTS=y', '' , d)}"