blob: f78644278f19f0b781b9548f36559cd7247eb0a4 [file] [log] [blame]
Matt Spinleraca1b152017-03-10 15:08:56 -06001SUMMARY = "OpenPower procedure control"
2DESCRIPTION = "Provides procedures that run against the host chipset"
3PR = "r1"
Patrick Venture8eb23612018-10-02 19:14:43 -07004PV = "1.0+git${SRCPV}"
Matt Spinler37619cc2017-10-04 13:07:06 -05005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
7
Matt Spinleraca1b152017-03-10 15:08:56 -06008S = "${WORKDIR}/git"
9
Andrew Geissler643013c2018-11-20 03:20:12 +000010inherit autotools obmc-phosphor-utils pkgconfig pythonnative
11inherit systemd
Matt Spinleraca1b152017-03-10 15:08:56 -060012
Matt Spinler37619cc2017-10-04 13:07:06 -050013SRC_URI += "git://github.com/openbmc/openpower-proc-control"
Andrew Geissler643013c2018-11-20 03:20:12 +000014SRCREV = "171fbdf683976ee54d1aa13745523b355d751ff5"
Matt Spinler20c9cd02017-09-18 15:52:40 -050015
16DEPENDS += " \
17 autoconf-archive-native \
18 phosphor-logging \
19 phosphor-dbus-interfaces \
20 openpower-dbus-interfaces \
21 "
22
23RDEPENDS_${PN} += " \
24 phosphor-logging \
25 phosphor-dbus-interfaces \
26 openpower-dbus-interfaces \
27 "
Andrew Geissler643013c2018-11-20 03:20:12 +000028
29TEMPLATE = "pcie-poweroff@.service"
30INSTANCE_FORMAT = "pcie-poweroff@{}.service"
31INSTANCES = "${@compose_list(d, 'INSTANCE_FORMAT', 'OBMC_CHASSIS_INSTANCES')}"
32SYSTEMD_PACKAGES = "${PN}"
33SYSTEMD_SERVICE_${PN} = "${TEMPLATE} ${INSTANCES}"