Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | require recipes-core/systemd/systemd.inc |
| 2 | |
| 3 | DEPENDS = "intltool-native libcap util-linux gnu-efi" |
| 4 | |
| 5 | SRC_URI += "file://0001-use-lnr-wrapper-instead-of-looking-for-relative-opti.patch" |
| 6 | |
| 7 | inherit autotools pkgconfig gettext |
| 8 | inherit deploy |
| 9 | |
| 10 | EXTRA_OECONF = " --enable-gnuefi \ |
| 11 | --with-efi-includedir=${STAGING_INCDIR} \ |
| 12 | --with-efi-ldsdir=${STAGING_LIBDIR} \ |
| 13 | --with-efi-libdir=${STAGING_LIBDIR} \ |
| 14 | --disable-manpages \ |
| 15 | " |
| 16 | |
| 17 | # Imported from gummiboot recipe |
| 18 | TUNE_CCARGS_remove = "-mfpmath=sse" |
| 19 | COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux" |
| 20 | |
| 21 | do_compile() { |
| 22 | SYSTEMD_BOOT_EFI_ARCH="ia32" |
| 23 | if [ "${TARGET_ARCH}" = "x86_64" ]; then |
| 24 | SYSTEMD_BOOT_EFI_ARCH="x64" |
| 25 | fi |
| 26 | |
| 27 | oe_runmake systemd-boot${SYSTEMD_BOOT_EFI_ARCH}.efi |
| 28 | } |
| 29 | |
| 30 | do_install() { |
| 31 | # Bypass systemd installation with a NOP |
| 32 | : |
| 33 | } |
| 34 | |
| 35 | do_deploy () { |
| 36 | install ${B}/systemd-boot*.efi ${DEPLOYDIR} |
| 37 | } |
| 38 | addtask deploy before do_build after do_compile |