Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "name server information handler" |
| 2 | DESCRIPTION = "Resolvconf is a framework for keeping track of the system's \ |
| 3 | information about currently available nameservers. It sets \ |
| 4 | itself up as the intermediary between programs that supply \ |
| 5 | nameserver information and programs that need nameserver \ |
| 6 | information." |
| 7 | SECTION = "console/network" |
| 8 | LICENSE = "GPLv2+" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b" |
| 10 | AUTHOR = "Thomas Hood" |
| 11 | HOMEPAGE = "http://packages.debian.org/resolvconf" |
| 12 | RDEPENDS_${PN} = "bash" |
| 13 | |
| 14 | SRC_URI = "git://salsa.debian.org/debian/resolvconf.git;protocol=https \ |
| 15 | file://fix-path-for-busybox.patch \ |
| 16 | file://99_resolvconf \ |
| 17 | " |
| 18 | |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 19 | SRCREV = "d001dd2b7ce4c854eaa29e46b9640ab66c6e70bb" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | # the package is taken from snapshots.debian.org; that source is static and goes stale |
| 24 | # so we check the latest upstream from a directory that does get updated |
| 25 | UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/r/resolvconf/" |
| 26 | |
| 27 | inherit allarch |
| 28 | |
| 29 | do_compile () { |
| 30 | : |
| 31 | } |
| 32 | |
| 33 | do_install () { |
| 34 | install -d ${D}${sysconfdir}/default/volatiles |
| 35 | install -m 0644 ${WORKDIR}/99_resolvconf ${D}${sysconfdir}/default/volatiles |
| 36 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 37 | install -d ${D}${sysconfdir}/tmpfiles.d |
| 38 | echo "d /run/${BPN}/interface - - - -" \ |
| 39 | > ${D}${sysconfdir}/tmpfiles.d/resolvconf.conf |
| 40 | fi |
| 41 | install -d ${D}${base_libdir}/${BPN} |
| 42 | install -d ${D}${sysconfdir}/${BPN} |
| 43 | ln -snf ${localstatedir}/run/${BPN} ${D}${sysconfdir}/${BPN}/run |
| 44 | install -d ${D}${sysconfdir} ${D}${base_sbindir} |
| 45 | install -d ${D}${mandir}/man8 ${D}${docdir}/${P} |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 46 | cp -pPR etc/resolvconf ${D}${sysconfdir}/ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 47 | chown -R root:root ${D}${sysconfdir}/ |
| 48 | install -m 0755 bin/resolvconf ${D}${base_sbindir}/ |
| 49 | install -m 0755 bin/list-records ${D}${base_libdir}/${BPN} |
| 50 | install -d ${D}/${sysconfdir}/network/if-up.d |
| 51 | install -m 0755 debian/resolvconf.000resolvconf.if-up ${D}/${sysconfdir}/network/if-up.d/000resolvconf |
| 52 | install -d ${D}/${sysconfdir}/network/if-down.d |
| 53 | install -m 0755 debian/resolvconf.resolvconf.if-down ${D}/${sysconfdir}/network/if-down.d/resolvconf |
| 54 | install -m 0644 README ${D}${docdir}/${P}/ |
| 55 | install -m 0644 man/resolvconf.8 ${D}${mandir}/man8/ |
| 56 | } |
| 57 | |
| 58 | pkg_postinst_${PN} () { |
| 59 | if [ -z "$D" ]; then |
| 60 | if command -v systemd-tmpfiles >/dev/null; then |
| 61 | systemd-tmpfiles --create ${sysconfdir}/tmpfiles.d/resolvconf.conf |
| 62 | elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then |
| 63 | ${sysconfdir}/init.d/populate-volatile.sh update |
| 64 | fi |
| 65 | fi |
| 66 | } |
| 67 | |
| 68 | FILES_${PN} += "${base_libdir}/${BPN}" |