Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 1 | SUMMARY = "A collection of tools, libraries and tests for shader compilation" |
| 2 | DESCRIPTION = "The Shaderc library provides an API for compiling GLSL/HLSL \ |
| 3 | source code to SPIRV modules. It has been shipping in the Android NDK since version r12b." |
| 4 | SECTION = "graphics" |
| 5 | HOMEPAGE = "https://github.com/google/shaderc" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 8 | |
| 9 | SRCREV = "1fce59794079f90ceb091190adbbb5499acd4e95" |
| 10 | SRC_URI = "git://github.com/google/shaderc.git;protocol=https;branch=main \ |
| 11 | file://0001-Fix-the-link-order-of-libglslang-and-libHLSL.patch \ |
| 12 | file://0003-cmake-de-vendor-libs-and-disable-git-versioning.patch \ |
| 13 | " |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit cmake python3native |
| 17 | |
| 18 | DEPENDS = "spirv-tools glslang" |
| 19 | |
| 20 | EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DSHADERC_SKIP_TESTS=ON" |
| 21 | |
| 22 | do_configure_prepend() { |
| 23 | # TODO: probably there is better solution for this. |
| 24 | # I dont know any method for get the version of a receipe in DEPENDS |
| 25 | # so do this ugly hack |
| 26 | cat <<- EOF > ${S}/glslc/src/build-version.inc |
| 27 | "${PV}\\n" |
| 28 | "$(pkg-config --modversion SPIRV-Tools)\\n" |
| 29 | "$(glslangValidator --version | head -1 | cut -d' ' -f3)\\n" |
| 30 | EOF |
| 31 | } |
| 32 | |
| 33 | BBCLASSEXTEND = "native nativesdk" |