Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "General purpose cryptographic library based on the code from GnuPG" |
| 2 | HOMEPAGE = "http://directory.fsf.org/project/libgcrypt/" |
| 3 | BUGTRACKER = "https://bugs.g10code.com/gnupg/index" |
| 4 | SECTION = "libs" |
| 5 | |
| 6 | # helper program gcryptrnd and getrandom are under GPL, rest LGPL |
| 7 | LICENSE = "GPLv2+ & LGPLv2.1+ & GPLv3+" |
| 8 | LICENSE_${PN} = "LGPLv2.1+" |
| 9 | LICENSE_${PN}-dev = "GPLv2+ & LGPLv2.1+" |
| 10 | LICENSE_dumpsexp-dev = "GPLv3+" |
| 11 | |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 13 | file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff \ |
| 14 | file://LICENSES;md5=840e3bcb754e5046ffeda7619034cbd8" |
| 15 | |
| 16 | DEPENDS = "libgpg-error" |
| 17 | |
| 18 | UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html" |
| 19 | SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.bz2 \ |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame^] | 20 | file://0001-libgcrypt-fix-m4-file-for-oe-core.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | file://0003-tests-bench-slope.c-workaround-ICE-failure-on-mips-w.patch \ |
| 22 | file://0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \ |
| 23 | file://0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch \ |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame^] | 24 | file://0001-Prefetch-GCM-look-up-tables.patch \ |
| 25 | file://0002-AES-move-look-up-tables-to-.data-section-and-unshare.patch \ |
| 26 | file://0003-GCM-move-look-up-table-to-.data-section-and-unshare-.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 27 | " |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame^] | 28 | SRC_URI[md5sum] = "348cc4601ca34307fc6cd6c945467743" |
| 29 | SRC_URI[sha256sum] = "3b4a2a94cb637eff5bdebbcaf46f4d95c4f25206f459809339cdada0eb577ac3" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 30 | |
| 31 | BINCONFIG = "${bindir}/libgcrypt-config" |
| 32 | |
| 33 | inherit autotools texinfo binconfig-disabled pkgconfig |
| 34 | |
| 35 | EXTRA_OECONF = "--disable-asm" |
| 36 | EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'" |
| 37 | |
| 38 | PACKAGECONFIG ??= "capabilities" |
| 39 | PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap" |
| 40 | |
| 41 | do_configure_prepend () { |
| 42 | # Else this could be used in preference to the one in aclocal-copy |
| 43 | rm -f ${S}/m4/gpg-error.m4 |
| 44 | } |
| 45 | |
| 46 | # libgcrypt.pc is added locally and thus installed here |
| 47 | do_install_append() { |
| 48 | install -d ${D}/${libdir}/pkgconfig |
| 49 | install -m 0644 ${B}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/ |
| 50 | } |
| 51 | |
| 52 | PACKAGES =+ "dumpsexp-dev" |
| 53 | |
| 54 | FILES_${PN}-dev += "${bindir}/hmac256" |
| 55 | FILES_dumpsexp-dev += "${bindir}/dumpsexp" |
| 56 | |
| 57 | BBCLASSEXTEND = "native nativesdk" |