Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Cross-platform audio output library and plugins" |
| 2 | DESCRIPTION = "Libao is a cross-platform audio library that allows programs to \ |
| 3 | output audio using a simple API on a wide variety of platforms." |
| 4 | SECTION = "multimedia" |
| 5 | HOMEPAGE = "https://www.xiph.org/ao/" |
| 6 | |
| 7 | LICENSE = "GPLv2" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 9 | |
| 10 | SRC_URI="http://downloads.xiph.org/releases/ao/${BP}.tar.gz" |
| 11 | SRC_URI[md5sum] = "9f5dd20d7e95fd0dd72df5353829f097" |
| 12 | SRC_URI[sha256sum] = "03ad231ad1f9d64b52474392d63c31197b0bc7bd416e58b1c10a329a5ed89caf" |
| 13 | |
| 14 | inherit autotools |
| 15 | |
| 16 | PACKAGES += "${BPN}-ckport" |
| 17 | PACKAGES_DYNAMIC += "^${BPN}-plugin-.*" |
| 18 | |
| 19 | do_install_append () { |
| 20 | find "${D}" -name '*.la' -exec rm -f {} + |
| 21 | } |
| 22 | |
| 23 | python populate_packages_prepend () { |
| 24 | rootdir = bb.data.expand('${libdir}/ao/plugins-4', d) |
| 25 | rootdir_dbg = bb.data.expand('${libdir}/ao/plugins-4/.debug', d) |
| 26 | do_split_packages(d, rootdir, '^(.*)\.so$', output_pattern='${BPN}-plugin-%s', description='AO %s plugin') |
| 27 | do_split_packages(d, rootdir_dbg, '^(.*)\.so$', output_pattern='${BPN}-plugin-%s-dbg', description='AO %s plugin debug data') |
| 28 | } |
| 29 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 30 | PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'alsa pulseaudio', d)}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 31 | PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib" |
| 32 | PACKAGECONFIG[pulseaudio] = "--enable-pulse,--disable-pulse,pulseaudio" |
| 33 | FILES_${BPN}-ckport = "${libdir}/ckport" |