blob: 4cb41d99f0b91084a19916991c44e73d4ec74403 [file] [log] [blame]
Thang Q. Nguyen7b3a9f52023-10-19 10:19:11 +07001FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
2
3SRC_URI:append = " file://host_eid"
4
5SYSTEMD_SERVICE:${PN}:remove = " \
6 pldmSoftPowerOff.service \
7 "
8SRC_URI:remove = "file://pldm-softpoweroff"
9
Thang Q. Nguyen7b3a9f52023-10-19 10:19:11 +070010do_install:append() {
11 install -d ${D}/${datadir}/pldm
12 install ${WORKDIR}/host_eid ${D}/${datadir}/pldm/
13 LINK="${D}${systemd_unitdir}/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
14 rm -f $LINK
15 LINK="${D}${systemd_unitdir}/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
16 rm -f $LINK
17 rm -f ${D}${systemd_unitdir}/system/pldmSoftPowerOff.service
18 rm -rf ${D}/${bindir}/pldm-softpoweroff
19}